Erro "Não é possível conectar-se ao Banco de Dados SQL, ErrorCode=SqlFailedToConnect" na migração para a nuvem do Business Central
Este artigo resolve a mensagem de erro "Não é possível conectar-se ao Banco de Dados SQL, ErrorCode=SqlFailedToConnect" que ocorre quando você tenta se conectar a um banco de dados SQL na migração para a nuvem do Business Central.
Sintomas
Ao tentar se conectar a um banco de dados SQL na migração para a nuvem do Business Central, você recebe a seguinte mensagem de erro:
Não é possível conectar-se ao Banco de Dados SQL, ErrorCode=SqlFailedToConnect.
Essa mensagem de erro geralmente ocorre junto com a seguinte mensagem de erro:
Verifique se a configuração do serviço vinculado está correta e se o firewall do Banco de Dados SQL permite que o runtime de integração seja acessado.
Motivo
Pode haver vários motivos para a mensagem de erro. O motivo mais comum é retornado dentro da mensagem de erro longa, por exemplo:
Problemas com a conta de usuário:
Falha no login do usuário...
A senha da conta precisa ser alterada.
A conta está desativada.
O SQL Server não está em execução ou o acesso remoto ao SQL Server está desabilitado:
O servidor não foi encontrado ou não estava acessível. Verifique se o nome de instância está correto e se o SQL Server está configurado para permitir conexões remotas.
Resolução
Para resolver esse problema, execute o seguinte comando do Windows PowerShell no host do Integration Runtime. Se o host do Integration Runtime não puder se conectar, ele retornará um erro descritivo.
sqlcmd –S "{SQL Server Name}" -d "{Database Name}" -U "{SQL Server Authenticated User Name}" -P "{PlaceholderSQLServerAuthenticatedPassword}" -Q 'select * from [dbo].[Intelligent Cloud]'
Para permitir que o endereço IP do cliente do Integration Runtime acesse o SQL Server, execute o seguinte comando no banco de dados mestre local:
sp_set_firewall_rule
Para permitir o acesso remoto ao SQL Server, execute o seguinte comando:
run sp_configure 'remote access', 1;