Falha de backup do estado do sistema do agente dos Serviços de Recuperação do Microsoft Azure (ID do erro 8007007B)
Este artigo descreve os sintomas e a resolução de um erro que ocorre quando você faz backup do Estado do Sistema usando o Agente dos Serviços de Recuperação do Microsoft Azure (MARS).
Versão original do produto: Backup do Azure
Número original do KB: 4053355
Sintomas
Uma das seguintes mensagens de erro é exibida na guia Erros da caixa de diálogo Detalhes do Trabalho que corresponde a um trabalho de backup de Estado do Sistema com falha no console do Agente dos Serviços de Recuperação do Microsoft Azure.
Não é possível executar a operação porque o trabalho de backup do Windows Server falhou com a mensagem de erro: nenhum dos itens incluídos no backup foi copiado. Erro detalhado: O nome do arquivo, o nome do diretório ou a sintaxe do rótulo do volume estão incorretos HResult: 80780049 DetailedHResult: 8007007B Ir para https://go.microsoft.com/fwlink/?linkid=847810 corrigir isso. (0x1873D)
O Windows Server falhou ao realizar o backup do estado do sistema porque um gravador do sistema relatou um caminho inválido. Mensagem de erro do Backup do Windows Server: O nome do arquivo, o nome do diretório ou a sintaxe do rótulo do volume estão incorretos HResult: 80780049 DetailedHResult: 8007007B Ir para https://go.microsoft.com/fwlink/?linkid=859092 corrigir isso. (0x18770)
Quando você clica em Logs de Falha do WSB, é aberto um arquivo que contém uma mensagem de erro semelhante à seguinte:
Erro no backup da enumeração Systemroot_pathduring: Erro [0x8007007b] O nome do arquivo, o nome do diretório ou a sintaxe do rótulo do volume estão incorretos.
Motivo
Esse erro ocorre quando a especificação de arquivo necessária para enumerar arquivos que devem ser copiados como parte do Estado do Sistema do Windows Server é atualizada incorretamente.
Resolução
Aviso
Poderão ocorrer sérios problemas se você modificar o Registro incorretamente com o Editor do Registro ou outro método. Talvez seja necessária a reinstalação do sistema operacional. A Microsoft não pode garantir que esses problemas possam ser resolvidos. Modifique o Registro por sua conta e risco.
Para garantir que a especificação do arquivo seja atualizada, siga estas etapas:
No arquivo que é aberto quando você clica em Logs de Falha do WSB, verifique se o Systemroot_path está correto. Por exemplo, Systemroot_path na mensagem de erro a seguir deve ser
C:\Windows\\systemroot\
semelhante a:Erro no backup de c:\windows\systemroot\ durante a enumeração: Erro [0x8007007b] O nome do arquivo, o nome do diretório ou a sintaxe do rótulo do volume estão incorretos.
Execute o comando a seguir, em um prompt de comandos com privilégios elevados:
diskshadow /l Output_File_Path
Observação
O espaço reservado Output_File_Path deve ser
C:\outputfilepath.txt
semelhante a .Digite os seguintes comandos em um prompt DISKSHADOW e pressione Enter após cada comando:
list writers detailed exit
Abra o arquivo de saída especificado na etapa 2.
Localize a linha que contém Systemroot_path (
C:\Windows\\systemroot\
em nosso exemplo acima). Por exemplo, a linha deve ser semelhante à seguinte: Lista de arquivos: Caminho = Systemroot_path\system32\drivers, Filespec = File_Spec_PathPor exemplo:
Lista de arquivos: caminho =
C:\windows\\systemroot\system32\drivers
, filespec = winmad.sysAbra o Editor do Registro. Para fazer isso, clique com o botão direito do mouse em Iniciar, clique em Executar, digite regedit na caixa Abrir e clique em OK.
Localize a seguinte subchave:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services
Clique com o botão direito do mouse em Serviços e clique em Localizar.
Na caixa Localizar, digite o caminho File_Spec_Path encontrado na etapa 5 e clique em Localizar Próximo.
Exemplo:
Os resultados da pesquisa apresentarão uma chave do Registro chamada ImagePath. Se o valor tiver uma barra invertida à esquerda '', clique duas vezes nesse valor e remova-o. Se o valor não começar com uma barra invertida, envie uma solicitação de suporte do portal do Azure.
Antes da alteração Depois da alteração Volte para o console do MARS Agent e inicie um backup do estado do sistema clicando em Fazer backup agora.
Entre em contato conosco para obter ajuda
Se você tiver dúvidas ou precisar de ajuda, crie uma solicitação de suporte ou peça ajuda à comunidade de suporte do Azure. Você também pode enviar comentários sobre o produto para a comunidade de comentários do Azure.