Os trabalhos de HPC estão presos no modo de cancelamento e novos trabalhos não são iniciados
Este artigo fornece uma solução para problemas com trabalhos em execução presos no modo de cancelamento e novos trabalhos não podem se transformar em status de execução quando um banco de dados SQL do Azure está em uso para um banco de dados remoto HPC PACK.
Sintomas
Quando você cancela os trabalhos em execução, eles ficam presos no modo de cancelamento e os novos trabalhos enviados ainda estão na fila enquanto há nós de computação disponíveis para executar os trabalhos. Reiniciar os nós não ajuda.
Enquanto isso, o banco de dados de PaaS (plataforma como serviço) está atingindo 100% e você vê a seguinte mensagem de erro no log do agendador HPC:
O servidor do agendador está ocupado. Ele não pode lidar com a solicitação do cliente agora. Tente novamente mais tarde.
Motivo
Esse problema ocorre porque o nó principal está sobrecarregado porque o banco de dados PaaS está atingindo seu limite de desempenho.
Resolução
Para resolver esse problema, aumente a DTU (unidade de transação do banco de dados) para um SKU mais alto para o banco de dados do agendador no Azure que corresponda à sua carga de trabalho. A DTU inicial mínima necessária para o banco de dados do agendador HPC é de 100 DTU.
Referências
Para obter mais informações, consulte Etapa 1: Preparar os bancos de dados remotos.
Entre em contato conosco para obter ajuda
Se você tiver dúvidas ou precisar de ajuda, crie uma solicitação de suporte ou peça ajuda à comunidade de suporte do Azure. Você também pode enviar comentários sobre o produto para a comunidade de comentários do Azure.