Compartilhar via


Solucionar problemas do código de erro "PublicIPCountLimitReached"

Este artigo explica como identificar e resolver o erro "PublicIPCountLimitReached". Esse erro ocorre quando você tenta criar, atualizar ou atualizar um cluster do AKS (Serviço de Kubernetes do Azure). Esse erro também pode ser causado por qualquer outra ação que acione a criação de um endereço IP público, como a implantação de um Balanceador de Carga Público do tipo Serviço Kubernetes.

Sintomas

Uma criação, atualização, atualização ou outra operação de cluster do AKS que dispara a criação de um endereço IP público, como a implantação de um Serviço do Kubernetes que tem um Balanceador de Carga Público, falha e retorna uma mensagem de erro "PublicIPCountLimitReached".

Motivo

Esse erro ocorrerá se você tiver atingido o número máximo de endereços IP públicos permitidos para sua assinatura. O limite varia de acordo com o seu tipo de assinatura. Para obter mais informações sobre limites de endereços IP públicos, consulte este guia detalhado.

Solução

Para aumentar o limite ou a cota de IP público para sua assinatura, siga estas etapas:

  1. Navegue até o portal do Azure e selecione as assinaturas para as quais você está executando a operação.

  2. Na seção Configurações, selecione Uso + cotas. Defina o Provedor como Rede e, opcionalmente, filtre pela região do cluster do AKS.

  3. Localize o registro Endereços IP Públicos . Na mesma linha, selecione o botão Criar uma nova solicitação de suporte.

    Captura de tela que mostra como criar uma solicitação de suporte para aumento de cota.

  4. Na página Nova solicitação de suporte, especifique o novo limite necessário e siga as instruções para criar a solicitação de suporte.

    Captura de tela de como especificar o novo limite para endereços IP públicos.

Depois que a alteração de cota entrar em vigor, repita a operação que inicialmente disparou o erro "PublicIPCountLimitReached".

Entre em contato conosco para obter ajuda

Se você tiver dúvidas ou precisar de ajuda, crie uma solicitação de suporte ou peça ajuda à comunidade de suporte do Azure. Você também pode enviar comentários sobre o produto para a comunidade de comentários do Azure.