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O endereço IP do cliente não pode acessar o servidor de API

Este artigo descreve como corrigir problemas que ocorrem quando você não consegue se conectar a um cluster do AKS (Serviço de Kubernetes do Azure) porque o endereço IP do cliente não pode acessar o servidor de API do AKS.

Pré-requisitos

Sintomas

Ao tentar acessar recursos do Kubernetes, como mamespaces e cargas de trabalho do portal do Azure, você pode encontrar os seguintes erros:

Erro de rede

Não é possível acessar o servidor de API 'https://< API-server-FQDN>' ou o servidor de API está muito ocupado para responder. Verifique suas configurações de rede e atualize para tentar novamente.

Captura de tela de mamespaces no recurso do AKS.

Motivo

Os intervalos de IP autorizados pelo servidor de API podem ter sido habilitados no servidor de API do cluster, mas o endereço IP do cliente não foi incluído nos intervalos de IP. Para verificar se esse recurso foi habilitado, verifique se o seguinte comando az aks show na CLI do Azure produz uma lista de intervalos de IP:

az aks show --resource-group <cluster-resource-group> \
    --name <cluster-name> \
    --query apiServerAccessProfile.authorizedIpRanges

Solução

Examine os intervalos autorizados pelo servidor de API do cluster e adicione o endereço IP do cliente dentro desse intervalo.

Observação

  1. Você acessa o servidor de API de uma rede corporativa em que o tráfego é roteado por meio de um servidor proxy ou firewall? Em seguida, pergunte ao administrador da rede antes de adicionar o endereço IP do cliente à lista de intervalos autorizados para o servidor de API.

  2. Pergunte também ao administrador do cluster antes de adicionar o endereço IP do cliente, pois pode haver preocupações de segurança com a adição de um endereço IP temporário à lista de intervalos autorizados.

  1. Navegue até o cluster no portal do Azure.

  2. No menu à esquerda, localize Configurações e selecione Rede.

  3. Na página Rede , selecione a guia Visão geral .

  4. Selecione Gerenciar em Configurações de recursos.

  5. No painel Intervalos de IP autorizados, adicione o endereço IP do cliente, conforme mostrado na captura de tela a seguir:

    Captura de tela do painel Authorized-ip-ranges.

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