Erro "ServiceUnavailable (409) - o recurso solicitado não está disponível no local"
Este artigo discute como resolver o erro ServiceUnavailable (409) ("O recurso solicitado não está disponível no local", '<region-name>' neste momento") que ocorre quando você tenta implantar um recurso em Instâncias de Contêiner do Microsoft Azure.
Sintomas
Você recebe uma mensagem de erro semelhante ao seguinte texto:
O recurso solicitado não está disponível no local 'usgovvirginia' no momento. Tente novamente com uma solicitação de recurso diferente ou em outro local. Recurso solicitado: '2' CPU '4' GB de memória 'Linux' OS rede virtual. Serviço Indisponível (409).
Motivo
Esse problema pode ocorrer se um recurso não estiver disponível em determinadas regiões ou se houver falta de capacidade. Esse problema geralmente é intermitente.
Solução
Para determinar se você pode implantar em uma região disponível, consulte Disponibilidade de recursos e limites de cota para Instâncias de Contêiner do Azure.
Para determinar quais recursos estão disponíveis em sua região, use a API REST de Localização – Recursos de Lista . Você também pode verificar os recursos disponíveis por região selecionando o botão "Experimentar" nesse artigo.
Se você estiver implantando em uma região disponível e não houver limitação de recursos, repita a implantação.
Entre em contato conosco para obter ajuda
Se você tiver dúvidas ou precisar de ajuda, crie uma solicitação de suporte ou peça ajuda à comunidade de suporte do Azure. Você também pode enviar comentários sobre o produto para a comunidade de comentários do Azure.