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Um erro é exibido em um relatório de sincronização de diretório: Esta empresa excedeu o número de objetos que podem ser sincronizados

Este artigo descreve como aumentar a cota do serviço de diretório do Active Directory para sincronização de diretório em um ambiente do Office 365, Azure ou Microsoft Intune.

Versão original do produto: Serviços de Nuvem (funções Web/funções de trabalho), ID do Microsoft Entra, Microsoft Intune, Backup do Azure, Gerenciamento de Usuário e Domínio do Office 365
Número original do KB: 2812409

Sintomas

Você recebe uma mensagem de email de MSOnlineServicesTeam@MicrosoftOnline.com que contém a seguinte mensagem de erro:

Erro 016: A sincronização foi interrompida. Esta empresa excedeu o número de objetos que podem ser sincronizados. Entre em contato com o suporte do Microsoft Online Services.

Observação

Este artigo também pode ser usado se você quiser apenas solicitar o aumento da cota do serviço de diretório caso esteja planejando ter mais do que o número permitido de objetos em um serviço de nuvem da Microsoft, como Office 365, Azure ou Microsoft Intune, e não use a sincronização do Active Directory. A cota atual do serviço de diretório na ID do Microsoft Entra é de 50.000 objetos.

Motivo

Esse problema ocorre porque o número de objetos que você criou em sua ID do Microsoft Entra excede o limite do serviço de diretório. O Microsoft Entra ID limita o número de objetos que podem ser criados por organização. Grupos, contatos e objetos de usuário na sua organização do Microsoft Entra são contados como parte do uso do diretório da sua organização.

Sua cota de serviço de diretório padrão é calculada de acordo com as seguintes diretrizes:

  • Se você não tiver nenhum domínio verificado, a cota atual do serviço de diretório na ID do Microsoft Entra será de 50.000 objetos.

    1. Se sua organização foi criada antes de 5 de outubro de 2011, sua cota de serviço de diretório padrão é de 10.000 objetos.
    2. Se sua organização foi criada após 5 de outubro de 2011 e antes de maio de 2012, sua cota de serviço de diretório padrão é de 20.000 objetos.
    3. Se sua organização foi criada após maio de 2012, sua cota de serviço de diretório padrão é de 50.000 objetos.
  • Se você tiver pelo menos um domínio verificado, a cota de serviço de diretório padrão na ID do Microsoft Entra será de 300.000 objetos.

Resolução

Se o número de grupos, contatos e objetos de usuário no Active Directory local exceder sua cota de serviço de diretório, você poderá solicitar um aumento na limitação de cota de serviço de diretório para sua empresa. Esse aumento permite sincronizar mais objetos do que o limite padrão atual quando você usa a sincronização de diretório.

Para continuar a criar objetos em sua organização, é preciso adicionar um domínio ou solicitar um aumento na sua cota de serviço de diretório. Para isso, use os métodos a seguir.

Método 1

Se você não tiver um domínio verificado, deverá adicionar um domínio para aumentar seu limite de cota para 300.000 objetos. Para obter mais informações, consulte Adicionar seu domínio.

Método 2

Se você tiver mais de 300.000 objetos em seu serviço de diretório local do Active Directory, para aumentar o número de objetos que podem ser sincronizados além de 300.000, entre em contato com o Suporte da Microsoft.

Mais informações

Uma cota de serviço de diretório é implementada usando o serviço de nuvem como um método para limitar o número máximo de objetos que podem ser criados e ser de propriedade de uma única entidade de segurança. Todos os objetos que são sincronizados usando a sincronização de diretório para uma empresa têm o valor de criador/proprietário definido como o grupo de administradores padrão para essa empresa. Por exemplo, o grupo admins é definido da seguinte forma: admins@contoso1.microsoftonline.com. Portanto, essa configuração impede que os usuários criem um número ilimitado de objetos usando a sincronização de diretório. Se uma empresa tiver uma necessidade legítima de sincronizar mais do que o limite de cota do serviço de diretório, envie uma solicitação de serviço para o suporte técnico.

Perguntas frequentes

Pergunta 1: Os objetos que foram adicionados manualmente por meio do portal de serviço de nuvem ou por meio da API de serviço de nuvem, como Exchange Online PowerShell, contam para a cota da minha empresa online?

Resposta 1: Sim.

Pergunta 2: Os objetos excluídos contam para a cota da minha empresa online?

Resposta 2: Sim. Quando um cliente de serviço de nuvem exclui um objeto de uma empresa online, o objeto excluído é colocado em um contêiner de objetos excluídos no serviço de diretório. O objeto permanece no contêiner de objetos excluídos até que o tempo de vida da marca de exclusão expire. A validade é atualmente definida como 30 dias.

Por exemplo, considere o cenário a seguir. Uma empresa online está avaliando um serviço de nuvem usando um ambiente de Active Directory local de não produção. A organização do serviço de nuvem foi criada antes de 5 de outubro de 2011, e o limite de sincronização padrão é de 10.000 objetos. A empresa executa uma sincronização em massa de 8.000 objetos de grupo e objetos de contato usando a ferramenta de sincronização de diretório. Posteriormente, a empresa online decide fazer o seguinte:

  1. Exclua esses objetos de grupo e objetos de contato do ambiente Active Directory DS local de não produção da empresa.
  2. Adicione 8.000 objetos de usuário ao seu ambiente local de não produção do Active Directory DS.
  3. Sincronize as atualizações com sua empresa online.

Os 8.000 objetos de grupo e objetos de contato são movidos para o contêiner de objetos excluídos no serviço de diretório. Esses objetos continuam a consumir até 25% da cota da empresa online até serem removidos permanentemente após o período de marca de exclusão de 30 dias. Esse percentual é igual a 2.000 objetos, ou 8.000 × 25%. Portanto, depois de sincronizar os 5.000 novos objetos de usuário, a empresa online consumirá 10.000 objetos de sua cota disponível de Active Directory, 2.000 de objetos excluídos mais 8.000 de novos objetos de usuário. Durante o período de marcas de exclusão de 30 dias (e esse período pode coincidir com o período de avaliação da empresa online), a empresa online pode não conseguir incluir objetos adicionais usando a sincronização de diretório. Essa condição ocorre porque a cota do serviço de diretório da empresa online foi atingida.

Nesse cenário, a empresa online que está executando a avaliação do serviço de nuvem precisa reduzir o número de objetos em seu ambiente do Active Directory Domain Services local de não produção para concluir a avaliação do produto. No entanto, se a empresa online não puder reduzir o número de objetos, deverá solicitar um aumento em sua cota de serviço de diretório.

Pergunta 3: Ter mais de um domínio verificado significa que posso ter uma cota superior a 300.000 objetos?

Resposta 3: Não. Você receberá uma cota de diretório de 300.000 objetos se tiver um ou mais domínios verificados. Você não recebe uma cota de 300.000 objetos para cada domínio verificado registrado.

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