Não é possível entrar usando o SSO se o ADAL e o AD FS forem usados no Skype for Business
Número de KB original: 4508931
Sintomas
Novos usuários não podem entrar no Microsoft Skype for Business 2016 local usando o método SSO (Logon Único) quando a Biblioteca de Autenticação do Azure Active Directory (ADAL) e Serviços de Federação do Active Directory (AD FS) (AD FS) são usadas.
Os perfis existentes não são afetados por esse problema. Novos usuários ou usuários que excluíram seu perfil ao tentar entrar recebem esta mensagem de erro:
Ocorreu um erro.
Esse problema também ocorre em computadores recém-imagens se nenhum perfil de usuário foi criado.
Motivo
Esse problema ocorre porque o método de autenticação padrão muda para o WAM (Web Account Manager) após a atualização para o Microsoft Office 2016 versão 16.0.7967.0000 ou uma versão posterior.
Solução alternativa
Importante
Siga as etapas nesta seção com cuidado. Problemas graves podem ocorrer se você modificar o registro incorretamente. Faça backup do registro para restauração caso ocorram problemas.
Adicione uma das seguintes chaves de registro:
Adicione a
EnableWAM
chave a esta subchave:HKEY_CURRENT_USER\SOFTWARE\Policies\Microsoft\Office\16.0\Lync
Nome:
EnableWAM
Tipo: DWORD (32 bits)
Valor: 0x00000000Adicione a
EnableWAM
chave a esta subchave:HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Office\16.0\Lync
Nome:
EnableWAM
Tipo: DWORD (32 bits)
Valor: 0x00000000Adicione a
DisableADALatopWAM
chave a esta subchave:HKEY_CURRENT_USER\SOFTWARE\Microsoft\Office\16.0\Common\Identity
Nome:
DisableADALatopWAM
Tipo: DWORD (32 bits)
Valor: 1Observação
Há uma chave semelhante chamada
DisableADALatopWAMOverride
no mesmo local. Essa chave não é usada por Skype for Business. UseDisableADALatopWAM
se você escolher essa opção.
Mais informações
Para evitar esse problema, use a Autenticação Híbrida Moderna. Para obter mais informações, confira Visão geral e pré-requisitos de autenticação moderna híbrida para usá-la com servidores locais Skype for Business e Exchange.