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Os usuários do Exchange 2007 não conseguem exibir as informações de disponibilidade nas caixas de correio do Exchange 2003 Server

 

Tópico modificado em: 2008-04-15

Este tópico oferece informações sobre o que pode levar informações de disponibilidade de uma pasta pública a não serem replicadas entre os usuários do Microsoft Exchange Server 2003 e do Exchange Server 2007. Os usuários do Exchange 2007 não conseguem ver informações de disponibilidadede de usuários cujas caixas de correio estejam no servidor Exchange 2003. Para esses usuários, as informações de disponibilidade aparecem como cerquilhas na página do Assistente de Agendamento do Outlook.

Além disso, poderia haver vários eventos 4003 no servidor de Acesso para Cliente. Um evento 4003 indica uma falha na consulta de informações de disponibilidade de caixas de correio herdadas. Normalmente, essas informações são provenientes de pastas públicas. A seguir está um exemplo de um evento 4003.

ID do Evento: 4003

ID não processada do Evento: 4003

Categoria: Serviço de Disponibilidade

Origem : Disponibilidade do MSExchange

Tipo: Erro

Mensagem: Processo 4664[w3wp.exe:/LM/W3SVC/1/ROOT/EWS-1-128114978363374212]: Microsoft.Exchange.InfoWorker.Common.Availability.PublicFolderRequest falhou. A exceção retornada é Microsoft.Exchange.InfoWorker.Common.Availability.PublicFolderRequestProcessingException

Causas

As duas causas prováveis desse problema são:

  1. Por padrão, a opção "Requerer canal seguro (SSL)" está sececionada no diretório virtual da pasta pública do servidor de autoridade de certificação (CA) Esse problema pode ocorrer ser o nome no certificado não corresponder ao nome de domínio totalmente qualificado (FQDN) da URL armazenada no atributo InternalURL do Serviço da Web do Exchange.

  2. Autenticações baseadas em formulários são permitidas no Exchange Server 2003. Para obter mais informações sobre autenticação baseada em formulários, consulte Como configurar a autenticação baseada em formulários para o Outlook Web Access.

Resolução

Para resolver o problema, use uma ou mais das seguintes soluções, conforme aplicável à situação de sua organização.

Procedimento

Para modificar o atributo InternalURL

  1. No servidor de Acesso para Cliente, abra o Gerenciador do IIS.

  2. No site padrão, vá até o diretório virtual Público.

  3. Clique com o botão direito em Público e clique na página Propriedades.

  4. Na aba Segurança de Diretório, clique em Exibir Certificado e observe o nome em "Emitido para", por exemplo, mail.contoso.com.

  5. Inicie o Shell de Gerenciamento do Exchange.

  6. Modifique o atributo InternalURL digitando o seguinte cmdlet e, em seguida, pressionando Enter: Set-WebServicesVirtualDirectory -Identity "CAS_Server_Name\EWS (Site Padrão)" -InternalURL https://mail.contoso.com/ews/exchange.asmx

  7. Reinicie o Serviço de Administração do IIS.

Para desativar a autenticação baseada em formulários

  1. Abra o Gerenciador do Sistema do Exchange.

  2. Na árvore do console, expanda Servidores, expanda o servidor para o qual você deseja desativar autenticações baseadas em formulários e expanda Protocolos.

  3. Expanda HTTP, clique com o botão direito em Servidor Virtual do Exchange e, em seguida, clique em Propriedades.

  4. Na caixa de diálogo Propriedades do Exchange Virtual Server, na guia Configurações, no painel Outlook Web Access, desmarque Habilitar Autenticação com Base em Formulários.

  5. Clique em Aplicar e em OK.

  6. Reinicie o Serviço de Administração do IIS.