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O Office 2013 não pode fazer check-in de arquivos quando a LAN não tem acesso à Internet ou em algumas VPNs

Este artigo foi escrito por Warren Rath, engenheiro de escalonamento de suporte.

Nos casos em que a VPN causa esse problema, encontramos um problema no código do Windows (113100710844135), a correção está fora O cliente VPN de terceiros interrompe a conectividade com a Internet no Windows 7 SP1 ou Windows Server 2008 R2 SP1. Verificamos que o Palo Alto Networks Global Protect Client e o Juniper VPN funcionam com essa correção.

Os clientes estão usando soluções VPN de terceiros no Windows 7. Se os clientes migrarem para o Office 2013 de uma versão mais antiga do Office, eles poderão sofrer perda de funcionalidade no Office quando conectados via VPN. O Office 2013 dependia do NLA (Network Location Awareness) e algumas soluções VPN não funcionam corretamente com o NLA. Especificamente, se o software VPN não definir um gateway padrão. Nesse caso, o NLA sempre relatará que o cliente não está conectado à Internet. Isso afeta o Office 2013, pois ele depende da conectividade com a Internet para algumas funções. Por exemplo, não há nenhum arquivo de ajuda no computador e toda a ajuda está na Internet. Se um cliente pressionar F1 em um aplicativo do Office 2013, ele sempre receberá um erro informando que não está conectado à Internet enquanto estiver conectado via VPN.

Sintomas

Os usuários sem acesso total à Internet podem não conseguir fazer check-in de arquivos do cliente do Office 2013, mesmo que haja uma boa conexão entre o cliente do Office e o servidor do SharePoint.

Motivo

Houve uma mudança de design entre o Office 2010 e o 2013, onde 2013 agora requer uma conexão com a Internet para algumas atividades. Alguns clientes já reclamaram desse problema e o grupo de produtos foi informado das limitações do projeto. (Mas nenhum hotfix está em andamento, um hotfix pode não ser possível, isso parece ser uma mudança significativa)

A raiz do problema parece ser que o Office 2013 tem uma dependência do NLA (Network Location Awareness). O NLA usa sondas para determinar se a conexão de rede tem "acesso à Internet". Do jeito que está, isso é de duas maneiras.

  1. Ele faz uma sondagem de DNS para dns.msftncsi.com. Espera uma resposta específica. A resposta deve ser 131.107.255.255. Se for, essa é a sonda DNS correta.
  2. Ele tenta se conectar https://www.msftncsi.com e recuperar o arquivo ncsi.txt. Dentro do arquivo, o texto deve ser "Microsoft NCSI".

Se ambas as condições acima forem atendidas, a conexão será marcada como tendo conectividade com a Internet, caso contrário, a conexão será marcada como sem conectividade com a Internet e alguns recursos do Office não funcionarão.

Solução alternativa

É possível configurar um servidor NCIS local (Indicador de Status da Conexão de Rede) em sua LAN que responderá à solicitação dos Clientes do Office e permitirá que o recurso do Office funcione.

Veja a postagem abaixo para obter informações e instruções relacionadas: