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Não é possível configurar o cliente de email padrão usando Política de Grupo

Sintomas

Quando você usa Política de Grupo para administrar o cliente de email padrão, não é possível localizar uma configuração para fazer essa configuração.

Motivo

Os modelos de Política de Grupo padrão do Microsoft Outlook não incluem uma configuração para configurar o cliente de email padrão.

Resolução

Observação

Siga as etapas nesta seção com cuidado. Sérios problemas poderão ocorrer caso você modifique o Registro incorretamente. Antes de modificá-lo, faça backup do Registro para restauração em caso de problemas.

Para definir o cliente de email padrão, siga as instruções para sua versão do Windows.

Windows 10 e Windows 8

Tanto Windows 10 quanto Windows 8 proteger a parte do registro que armazena as configurações padrão do aplicativo. Você deve usar uma política baseada em XML no Política de Grupo para definir o conjunto de aplicativos padrão. Siga estas etapas para criar a política e implantá-la.

Etapa 1. Criar um arquivo XML de associações de aplicativo

  1. No Windows, digite Aplicativos padrão (ou abra aplicativos padrão em Configurações).

  2. Selecione Escolher aplicativos padrão por protocolo.

  3. Role para localizar MAILTO na lista e defina o Outlook como o aplicativo padrão.

    A captura de tela mostra as etapas para definir o Outlook como o aplicativo padrão.

  4. Depois que o padrão for definido, use DISM para exportar esses valores para XML.

    Observação

    Anote o nome do arquivo e o local do arquivo que você cria.

  5. Em um prompt de comando elevado, digite o comando a seguir.

    Dism /Online /Export-DefaultAppAssociations:"F:\AppAssociations.xml"
    

    Observação

    • O arquivo XML será baseado nos padrões definidos para a conta de usuário usada para executar DISM.
    • Para verificar se o Outlook está definido como o aplicativo padrão para abrir links do MailTo, procure uma linha retornada no XML que se assemelha ao seguinte:
    <Association Identifier="mailto" ProgId="Outlook.URL.mailto.15" ApplicationName="Outlook 2016" />
    

Etapa 2. Implantar o arquivo XML das associações de aplicativo por meio do GPO

  1. No Windows, digite gpedit.msc para abrir a Política de Grupo Editor Local.

  2. Abramodelos administrativos deconfiguração> do computadorComponentes>>do Windows Explorador de Arquivos.

  3. Clique duas vezes na política Defina um arquivo de configuração de associações padrão e defina-o como Habilitado.

  4. Especifique o caminho para o arquivo XML de associações de aplicativo que você criou anteriormente.

    Observação

    Esse pode ser um caminho local ou um local de rede que todos os clientes podem acessar.

Essa política deve criar a seguinte chave no registro:

Subchave: HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\System

Valor da cadeia de caracteres: DefaultAssociationsConfiguration

Dados de valor: \ServerPath\AppAssociations.xml

Observação

Essa política funciona apenas para clientes ingressados no domínio.

Depois que essa política for definida, as associações de aplicativo padrão serão aplicadas depois que o usuário entrar novamente. Os links do MailTo agora abrirão uma mensagem de email do Outlook.

Windows 7

Para configurar o cliente de email padrão usando Política de Grupo, crie um modelo .adm personalizado. Em seguida, adicione esse modelo ao local Política de Grupo Editor para que você possa configurar a configuração da política. Para fazer isso, siga estas etapas:

  1. Crie um arquivo de texto no Bloco de Notas.

  2. Copie e cole o seguinte texto no arquivo de texto:

    CLASS MACHINE
    CATEGORY !!Default_E-mail_Client
     POLICY !!Default_Client
     KEYNAME "SOFTWARE\Clients\Mail"
     EXPLAIN !!Explain_Default_Client
      PART !!labeltext_Default_Client EDITTEXT
       VALUENAME ""
     DEFAULT "Microsoft Outlook"
       END PART
      END POLICY
    END CATEGORY
    
    [strings]
    Default_E-mail_Client="Default e-mail client policy"
    Default_Client="Default e-mail client"
    Explain_Default_Client="This policy configures Outlook as the default e-mail client"
    labeltext_Default_Client="Default E-mail Client:"
    Microsoft_Outlook="Microsoft Outlook"
    
  3. Salve o arquivo como DefaultEmailClient.adm.

  4. Feche o arquivo.

  5. Adicione o arquivo à Política de Grupo Editor Local.

    Nota As etapas para adicionar o arquivo DefaultEmailClient.adm no Local Política de Grupo Editor variam. Para obter mais informações, consulte sua documentação do Windows.

  6. Em Configuração do Computador, expanda Modelos Administrativos.

  7. Na árvore de política, selecione o nó de política de cliente de email padrão .

  8. No painel de detalhes, clique duas vezes na configuração padrão do cliente de email .

    Nota Se você não vir a configuração de política de cliente de email padrão no painel de detalhes do Política de Grupo Editor Local, verifique se as configurações de filtragem do editor Política de Grupo não escondem políticas não gerenciadas. Por exemplo, no Windows Server 2003, selecione Filtragem no menu Exibir . Em seguida, desmarque as configurações somente mostrar política que podem ser totalmente gerenciadas marcar caixa.

  9. Selecione Habilitado.

  10. Especifique o cliente de email padrão a ser configurado por essa política. (A seleção padrão é o Microsoft Outlook.)

    Nota Se você não tiver certeza sobre quais clientes de email estão registrados em uma estação de trabalho, examine as chaves na subchave a seguir no registro.

    HKEY_LOCAL_MACHINE\SOFTWARE\Clients\Mail

    O nome de cada chave é o nome de um cliente de email instalado na estação de trabalho.

  11. Selecione OK.

Mais informações

  • Em Windows 10 e Windows 8, os usuários podem definir manualmente essa opção em Configurações> do WindowsEscolher um aplicativo padrão para cada protocolo.
  • No Windows 7, o cliente de email padrão normalmente é configurado na guia Programas na caixa de diálogo Propriedades da Internet . No entanto, se você não for membro do grupo de administradores locais, talvez não tenha a permissão apropriada para fazer essa alteração. Isso ocorre porque a configuração é armazenada na sub-árvore HKEY_LOCAL_MACHINE no registro.