Erro "Isso não parece uma ID de usuário válida" quando um usuário tenta entrar no Microsoft 365
Problema
Quando um usuário tenta entrar no Microsoft 365, o usuário recebe a seguinte mensagem de erro:
Desculpe, isso não funcionou.
Esta não parece uma ID de usuário válida. Verifique se você digitou a ID de usuário atribuída a você por sua organização. Geralmente se parece someone@example.com com ou someone@example.onmicrosoft.com.
Motivo
Esse problema ocorrerá se o UPN (nome da entidade de usuário) do usuário no ambiente Active Directory local e o UPN do usuário em Microsoft Entra ID não corresponderem. Por exemplo, o problema ocorrerá se o UPN local for john@contoso.com e o MICROSOFT ENTRA UPN for john@contoso.onmicrosoft.com.
Essa situação pode ocorrer se o UPN do usuário for alterado, mas a sincronização de diretório ainda não ocorreu para sincronizar a alteração.
Solução
Para resolve esse problema, verifique se o sufixo UPN local é um domínio verificado e aguarde até a próxima vez que a sincronização do diretório for executada ou force a sincronização do diretório.
Para obter mais informações sobre como forçar a sincronização do diretório, acesse o seguinte site da Microsoft: Sincronização do diretório do Force
Informações adicionais
Ainda precisa de ajuda? Acesse a Microsoft Community.