Erro "Nenhuma caixa de correio de pasta pública ativa foi encontrada" e o lote de migração falha no comando Complete-MigrationBatch
Sintomas
Você está migrando pastas públicas do Microsoft Exchange Server 2019, 2016 ou 2013 local para o Exchange Online. O ambiente local tem vários domínios do Active Directory (AD).
Quando você executa o Complete-MigrationBatch
comando, o lote de migração entra em um estado de falha e gera a seguinte mensagem de erro:
"No active public folder mailboxes were found. This happens when no public folder mailboxes are provisioned or they are provisioned in 'HoldForMigration' mode."
Motivo
Esse problema ocorre porque a caixa de correio de pasta pública e a conta de usuário associada não estão no mesmo domínio do AD. Por exemplo, a conta de usuário associada à caixa de correio de pasta pública está em contoso.com e a caixa de correio está hospedada no Exchange Server em child.contoso.com.
Resolução
Para corrigir esse problema, mova a conta do AD associada à caixa de correio de pasta pública para o mesmo domínio do AD que hospeda o Exchange Server. Por exemplo, o Exchange Server está instalado no domínio raiz do AD (contoso.com) e a conta do AD associada à caixa de correio de pasta pública está no domínio filho (child.contoso.com). Nesse caso, mova a conta do AD associada à caixa de correio de pasta pública para o domínio raiz (contoso.com) e execute o Complete-MigrationBatch
comando novamente. Dependendo da versão do sistema operacional, você pode usar a Ferramenta de Migração do Active Directory ou o comando Move-ADObject para mover o usuário do AD entre domínios.
Por exemplo, execute o seguinte comando do PowerShell para mover o usuário do AD associado ao PFMBX4 do child.contoso.com para o contoso.com:
Move-ADObject -Identity "CN=PFMBX4,CN=Users,DC=Child,DC=contoso,DC=com" -TargetPath "CN=Users,DC=contoso,DC=com" -TargetServer dc1.contoso.com