Conflito de endereço proxy ao adicionar um endereço de email no Exchange Online
Sintomas
Ao tentar atribuir um endereço proxy a um destinatário de email novo ou existente no Exchange Online, você recebe uma mensagem de erro semelhante a um dos exemplos a seguir.
Erro 1
O endereço proxy "SMTP:<endereço> SMTP conflitante" já está sendo usado por "<domain.prod.outlook.com/Microsoft> Exchange Hosted Organizations/contoso.onmicrosoft.com/<forest>". Escolha outro endereço de proxy.
Erro 2
Uma chamada de ID do Microsoft Entra foi feita para manter o objeto em sincronia entre a ID do Microsoft Entra e o Exchange Online. No entanto, falhou. Mensagem de erro detalhada: Já existe outro objeto com o mesmo valor para a propriedade proxyAddresses. ConflictingObject: PublicFolder_<GUID>.
Exemplos de um destinatário de email incluem um usuário de email, caixa de correio de usuário, caixa de correio compartilhada, grupo de distribuição, Grupo do Microsoft 365 e MEPF (pasta pública habilitada para email).
Motivo
Causa 1
A primeira mensagem de erro ocorrerá se um objeto habilitado para email no Exchange Online usar o endereço proxy que você deseja atribuir.
Causa 2
A segunda mensagem de erro ocorrerá se um objeto MEPF que existe apenas na ID do Microsoft Entra usar o endereço proxy que você deseja atribuir.
Resolução
A resolução para o primeiro erro é verificar e remover qualquer endereço de proxy conflitante no Exchange Online.
A resolução para o segundo erro é verificar e remover qualquer endereço proxy conflitante no Exchange Online e verificar e remover qualquer endereço proxy conflitante na ID do Microsoft Entra.
Use a resolução apropriada, dependendo da mensagem de erro recebida. Em seguida, tente atribuir o endereço proxy novamente.
Verificar e remover qualquer endereço proxy conflitante no Exchange Online
Siga estas etapas para pesquisar objetos habilitados para email existentes no Exchange Online que usam o endereço proxy conflitante.
Para listar todos os destinatários de email que usam o endereço SMTP conflitante, execute o seguinte comando:
Get-EXORecipient -ResultSize unlimited | Where-Object {$_.EmailAddresses -match "<conflicting SMTP address>"} | fl Name, RecipientType, EmailAddresses
Se você não souber o endereço SMTP exato, execute o seguinte comando:
Get-EXORecipient -ResultSize unlimited | Where-Object {$_.EmailAddresses -match "<partial conflicting SMTP address>"} | fl Name, RecipientType, EmailAddresses
Um endereço proxy pode ser atribuído a apenas um objeto por vez. Depois de determinar qual objeto está em conflito, remova ou altere o endereço proxy associado a esse objeto.
Por exemplo, se o objeto for uma pasta pública habilitada para email, execute o seguinte comando para desabilitar a pasta pública para liberar o endereço de email usado:
Get-MailPublicFolder -ResultSize Unlimited | Where-Object {$_.EmailAddresses -match "<conflicting SMTP address>"} | Disable-MailPublicFolder
Verificar e remover qualquer endereço proxy conflitante na ID do Microsoft Entra
Importante
Essa resolução requer um servidor local com o Microsoft Entra Connect instalado. Se sua infraestrutura local estiver desativada, entre em contato com o Suporte da Microsoft.
Siga estas etapas para verificar e remover do Microsoft Entra todos os MEPFs que usam o endereço proxy conflitante. Essas etapas exigem um servidor local que execute o Microsoft Entra Connect versão 2.0 ou posterior.
Pesquise o endereço de proxy conflitante em todos os MEPFs locais executando o seguinte comando no EMS (Shell de Gerenciamento do Exchange) local:
Get-MailPublicFolder -ResultSize Unlimited | Where-Object {$_.EmailAddresses -match "<conflicting SMTP address>"}
Para cada MEPF local identificado na etapa 1, remova o endereço SMTP conflitante executando o seguinte comando no EMS local:
Set-MailPublicFolder -Identity <public folder name or GUID> -EmailAddresses @{remove="<conflicting SMTP address>"} -EmailAddressPolicyEnabled:$false
Esta etapa remove todos os conflitos de endereço de proxy no lado local para garantir que eles não sejam sincronizados com a ID do Microsoft Entra ou Exchange Online.
Se você removeu um endereço SMTP conflitante de qualquer MEPF local na etapa 2, aguarde até que a próxima sincronização agendada seja executada no servidor Microsoft Entra Connect ou inicie manualmente um ciclo de sincronização executando o seguinte comando do PowerShell:
Start-ADSyncSyncCycle -PolicyType Delta
A sincronização deve remover o endereço SMTP conflitante da ID do Microsoft Entra.
Se você não encontrou o endereço SMTP conflitante em nenhum MEPF local ou se a sincronização não removeu o endereço SMTP conflitante da ID do Microsoft Entra, pesquise a ID do Microsoft Entra para MEPFs que tenham o endereço SMTP conflitante. Para pesquisar MEPFs na ID do Microsoft Entra, use o cmdlet Get-ADSyncToolsAadObject do PowerShell no servidor do Microsoft Entra Connect. A pesquisa diferencia maiúsculas de minúsculas. Inclua o prefixo "smtp:" ao especificar o endereço SMTP.
$mailEnabledPublicFolders = Get-ADSyncToolsAadObject -SyncObjectType "PublicFolder" -Credential (Get-Credential)
$conflictingSmtpAddress = "smtp:<conflicting SMTP address>"
$mailEnabledPublicFolders | Where-Object {$_.ProxyAddresses -icontains $conflictingSmtpAddress} | Select SourceAnchor
Os resultados da pesquisa fornecem o SourceAnchor para cada MEPF que atende aos critérios de pesquisa.
Para cada MEPF identificado na etapa 4, remova o MEPF da ID do Microsoft Entra usando o cmdlet Remove-ADSyncToolsAadObject . Forneça o
SourceAnchor
valor do MEPF no formato Base64.$conflictingSourceAnchor= "SourceAnchor value"
Remove-ADSyncToolsAadObject -SourceAnchor $conflictingSourceAnchor -SyncObjectType "PublicFolder" -Credentials (Get-Credential)
Para obter um exemplo de uso de cmdlet, consulte Remove-ADSyncToolsAadObject exemplo 2.
Execute novamente a pesquisa de ID do Microsoft Entra na etapa 4. Desta vez, os resultados da pesquisa não devem retornar nenhum MEPF.