Compartilhar via


Solucionar problemas de FabricInternalServerError ou ServiceAllocationFailure implantando um serviço de nuvem (clássico) no Azure

Importante

Os Serviços de Nuvem (clássicos) estão obsoletos para todos os clientes desde 1º de setembro de 2024. Todas as implantações em execução existentes serão interrompidas e encerradas pela Microsoft e os dados serão perdidos permanentemente a partir de outubro de 2024. As novas implantações devem usar o novo modelo de implantação baseado no Azure Resource Manager Serviços de Nuvem do Azure (suporte estendido) .

Nesse artigo, você soluciona falhas de alocação em que o controlador de malha não consegue alocar ao implantar um serviço de nuvem do Azure (clássico).

Quando você implanta instâncias em um Serviço de Nuvem ou adiciona nova instâncias de função da Web ou de trabalho, o Microsoft Azure aloca recursos de computação.

Eventualmente, você pode receber mensagens de erro durante as operações, antes de alcançar os limites da assinatura do Azure.

Dica

As informações também poderão ser úteis caso você pretenda implantar serviços.

Sintoma

Navegue até o serviço de nuvem (clássico) no portal do Azure e, na barra lateral, selecione Log de operação (clássico) para exibir os logs.

Imagem que mostra a folha Log de operação (clássico).

Ao inspecionar os logs do seu serviço Cloud (clássico), você verá a seguinte exceção:

Exceção Mensagem de erro
FabricInternalServerError A operação falhou com o código de erro “InternalError” e errorMessage “O servidor encontrou um erro interno”. Tente novamente a solicitação.'.
ServiceAllocationFailure A operação falhou com o código de erro “InternalError” e errorMessage “O servidor encontrou um erro interno”. Tente novamente a solicitação.'.

Causa

FabricInternalServerError e ServiceAllocationFailure são exceções que podem ocorrer quando o controlador de malha falha na alocação de instâncias no cluster. A causa raiz varia se o serviço de nuvem estiver fixado ou não fixado.

Observação

Quando a primeira instância é implantada em um serviço de nuvem (em preparo ou em produção), esse serviço de nuvem é fixado a um cluster.

Com o tempo, os recursos deste pool de recursos podem ser totalmente utilizados. Se um serviço de nuvem fizer uma solicitação de alocação para mais recursos quando houver recursos insuficientes no pool de recursos fixado, a solicitação resultará em uma falha de alocação.

Solução

Siga as diretrizes para falhas de alocação nos cenários a seguir.

Não fixado em um cluster

Na primeira vez que você implanta um serviço de nuvem (clássico), o cluster fica desmarcado, portanto, o serviço de nuvem não está fixado. O Azure pode ter uma falha de implantação porque:

  • Você selecionou um tamanho específico que não está disponível na região.
  • A combinação dos tamanhos que são necessários em diferentes funções não está disponível na região.

Quando ocorre um erro de alocação nesse cenário, o curso de ação recomendado é verificar os tamanhos disponíveis na região e alterar o tamanho especificado anteriormente.

  1. Você pode verificar os tamanhos disponíveis em uma região na página de Produtos do serviço de nuvem (clássico).

    Observação

    A página de Produtos não mostrará a capacidade disponível. Para qualquer nova alocação, o Azure deve ser capaz de escolher o cluster ideal em sua região nesse ponto no tempo.

  2. Atualize o arquivo de definição de serviço para o seu serviço de nuvem (clássico) para especificar um tamanho de produto diferente da sua região.

Fixado em um cluster

Os serviços de nuvem existentes são fixados em um cluster. Quaisquer outras implantações do serviço de nuvem (clássico) acontecem no mesmo cluster.

Quando ocorre um erro de alocação nesse cenário, o curso de ação recomendado é reimplantar em um novo serviço de nuvem (clássico) e atualizar o registro CNAME.

Dica

Essa solução provavelmente será a mais bem-sucedida, pois permite que a plataforma escolha entre todos os clusters nessa região.

Observação

Essa solução não causará qualquer tempo de inatividade.

  1. Implante a carga de trabalho em um novo serviço de nuvem (clássico).

    Aviso

    Caso não deseje perder o endereço IP associado a esse slot de implantação, use a Solução 3 – manter o endereço IP.

  2. Atualize o registro CNAME ou A para direcionar o tráfego para o novo serviço de nuvem (clássico).

  3. Quando não houver mais tráfego sendo encaminhado ao local antigo, você pode excluir o serviço de nuvem antigo (clássico).

Veja Solucionar problemas de falha de alocação do serviço de nuvem (clássico) | Microsoft Docs para ver mais etapas de correção.

Próximas etapas

Para obter mais soluções para falhas de alocação e também informações básicas:

Se o seu problema do Azure não for abordado neste artigo, visite os fóruns do Azure no Microsoft Developer Network (MSDN) e Stack Overflow. Você pode postar o seu problema nesses fóruns ou postar em @AzureSupport no X. Você também pode enviar uma solicitação de suporte do Azure. Para enviar uma solicitação de suporte na página Suporte do Azure, selecione Obter suporte.