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P2V fails with Error 2910 (0x80070005) Access Denied

Symptom

When using Microsoft System Center Virtual Machine Manager 2008 to perform a Physical-to-Virtual conversion (P2V), the following error message appears during the Scan System phase.

Error (2910)
VMM does not have appropriate permissions to access the resource on the %server.
Access is denied (0x80070005)

Recommended Action
Ensure that Virtual Machine Manager has the appropriate rights to perform this action.
Additional Information: The Source computer is the machine intended to be virtualized in the P2V conversion.

Cause

This failure is typically caused by either of the following conditions:

• The credentials provided during the P2V wizard is not a member of the local ‘Administrators’ group on the Source computer.

• The Source computer does not allow remote WMI calls to the CIMV2 namespace for the credentials entered during the P2V wizard.

Resolution

To resolve the problem, follow these steps:

1. Make sure that the account used during the P2V wizard is a member of the local ‘Administrators’ group on the Source computer. Note Pay particular attention to this if the SCVMM server and Source computer are in different domains.

2. During the Scan System phase of the P2V conversion, SCVMM makes WMI calls to the CIMV2 namespace on the Source computer to pull basic system information. If these WMI calls fail, then the P2V conversion will also fail. To verify WMI connectivity to the CIMV2 namespace on the Source computer, perform the following actions from the SCVMM server:

a. Click Start , point to Run and type " WBEMtest" (without the quotes) in the Open box and click OK . This will open the WBEMtest window.

b. Click Connect in the upper right hand corner.

c. Now, connect to the CIMV2 namespace on the Source computer.

Example: \\Source\ROOT\CIMV2

                Note Be sure to use the name of your Source computer.

d. Then click Connect to complete the connection. This should connect without any errors displayed.

e. Just to confirm access to a sample object, select Open Class and type Win32_PhysicalMemory

f. You should see objects populate in the Object Editor window. The actual content returned is not as important as the fact that a remote connection to the CIMV2 namespace was established.

3. Open wmimgmt.msc and verify connectivity to the Local computer and also check the 'Remote Enable' permissions.

a. Click Start , point to Run and type wmimgmt.msc and click OK . This will open the WMI Control (Local).

b. Right click on the WMI Control (Local) node and select Properties .

c. Select the Security tab, highlight Root and then open security by clicking the Security button in the lower right.

d. Select "Remote Enable" permission for Everyone or the specific user account that you want to grant this permission to.

e. This action does not require a reboot.

4. Open dcomcnfg and verify that DCOM is running and also check the 'Remote Activation' permission.

a. Click Start , point to Run and type dcomcnfg and click OK . This will open the Component Services snap-in.|

b. Expand Component Service , then Computers , then My Computer . If My Computer has a red down arrow mark, it means that the service is not running. It will need to be started.

c. Right click on My Computer and select Properties and select the COM Security tab.

d. Click Edit Limits under the Launch and Activation Permissions section.

e. For the Everyone user give the "Remote Activation" permission or add the specific user account that you want to grant this permission to.

Note The following error message may occur if the appropriate WMI permission is not granted to the user:
Access Denied" with Error Code: 0x80041003

5. This problem can also occur if the OLE registry key is missing or has the incorrect value on the Source computer.

a. Start Registry Editor.

b. Locate the following path:
HKLM\SOFTWARE\Microsoft\OLE

c. This key should have a REG_SZ value EnableDCOM and a value of Y.

Comments

  • Anonymous
    December 20, 2010
    I tried to convert a fresh XP Pro installation, which is not in my domain. Same error. I did all on the list, but nothing changed.

  • Anonymous
    November 09, 2012
    I miss something. It happens sometimes (three times this year). That you test all above and everything's is right but it does not help. It's annoying. Because then you have to reinstall the server. And you should probably make a tool for this if I see all the people on the net with the same problems.  

  • Anonymous
    March 19, 2014
    Did not work!