11 月の更新プログラム適用後、Epson 社製プリンターでの印刷に失敗する事象について
11 月の更新プログラムを適用すると、一部のEpson 社製プリンター(SIDM (Dot Matrix)およびTM(POS)プリンター)での印刷に失敗する事象を確認しており、現在、マイクロソフトは、本事象の対策版のリリースに向け全力を尽くしております。一部の Windows に対しては、対策版の更新プログラムをリリースしております。(詳細は後述しております。)
本ブログは、11 月の更新プログラムにより発生する問題に対して、タイムリーに情報を発信することを目的としています。
そのため、掲載内容は、随時更新いたしますことご理解をいただけますようお願いいたします。
原因
11 月のセキュリティ更新プログラムには、GDI と呼ばれる Windows での描画処理を主に担当するモジュールに対し、セキュリティ上の脆弱性を解消する変更が含まれております。
この変更が影響し、Epson 社製のプリンター ドライバーの実装に依存して印刷の開始に必要な内部の処理が失敗することが原因で発生することを確認しております。
現時点では不特定多数のプリンターで発生するという情報はありません。広範囲に発生する事象ではないと判断しております。
回避策
本問題に対する、各OS の対策版の更新プログラムは、以下のとおりです。
補足: ※ 2017 年 12 月のセキュリティのみの更新プログラムには、本事象の対策は含まれておりません。
すべての Windows に対する、対策版更新プログラムのリリースが完了いたしました。対策版更新プログラムをご適用いただいていない Windows をお使いのお客様で、この現象に遭遇しているお客様は、一時的に 11 月のセキュリティ更新プログラムを削除することで本現象を回避することができます。しかしながら、セキュリティ更新プログラムの削除は、コンピューターが脆弱になる可能性があるため、弊社では推奨しておりません。この現象に対する対処策といたしましては、対策版更新プログラムをご適用いただくことを強く推奨いたします。