Udostępnij za pośrednictwem


Sporadyczne błędy połączeń występują podczas dodawania węzła do środowiska Always On w programie SQL Server

Podczas dodawania nowego węzła do istniejącego środowiska Always On występują sporadyczne błędy połączenia.

Symptomy

Podczas próby nawiązania połączenia z serwerem z uruchomionym programem Microsoft SQL Server pojawia się sporadycznie następujący komunikat o błędzie:

Połączenie zostało pomyślnie nawiązane z serwerem, ale wystąpił błąd podczas procesu logowania. (dostawca: Dostawca SSL, błąd: 0 — istniejące połączenie zostało wymuszone przez hosta zdalnego).

Przyczyna

Ten błąd może wystąpić, jeśli między bazą danych i serwerami aplikacji występuje niezgodność protokołów zabezpieczeń.

Rozwiązanie

Aby naprawić ten błąd, usuń niezgodność między protokołami zabezpieczeń. Węzeł Node1 szyfruje informacje przy użyciu protokołu AES128/256. Węzeł Node2 szyfruje informacje przy użyciu wersji RC4. Aby rozwiązać ten problem, wykonaj następujące kroki:

  1. Pobierz usługę IIS Crypto.

  2. Zainstaluj wersję graficznego interfejsu użytkownika narzędzia kryptograficznego usług IIS na serwerze.

  3. Konfigurowanie zestawów szyfrowania.

  4. Otwórz narzędzie kryptograficzne usług IIS na serwerze.

  5. W interfejsie kryptograficznym usług IIS wybierz pozycję Zestawy szyfrowania w panelu po lewej stronie.

  6. Na liście wyczyść wszystkie pola wyboru dla szyfrów rozpoczynających się od "TLS_DHE*".

    Uwaga 16.

    Lista może nie być w żadnej określonej kolejności.

  7. Po wyczyszeniu odpowiednich wyborów szyfrowania wybierz pozycję Zastosuj , aby zapisać zmiany.

    Zrzut ekranu przedstawiający wyczyszczenie wszystkich szyfrów, które nie są wymagane.

  8. Uruchom ponownie serwer.

    Po zastosowaniu zmian uruchom ponownie serwer, aby upewnić się, że nowa konfiguracja pakietu szyfrowania zostanie zastosowana.

Uwaga 16.

Ten proces rozwiązywania problemów wymusza, aby klient komunikował się przy użyciu innego zestawu szyfrowania, który ma ulepszoną implementację zabezpieczeń.

Zawsze upewnij się, że masz dostępne odpowiednie kopie zapasowe. Należy również rozważyć przetestowanie wszelkich zmian w kontrolowanym, przygotowanym lub testowym środowisku przed zastosowaniem ich do komputerów produkcyjnych. Jeśli problem będzie się powtarzać lub jeśli masz jakiekolwiek inne problemy, skontaktuj się z zespołem ds. sieci.

Zastrzeżenie dotyczące innych firm

Produkty innych firm omówione w tym artykule są wytwarzane przez producentów niezależnych od firmy Microsoft. Firma Microsoft nie udziela żadnych gwarancji, dorozumianych ani żadnego innego rodzaju, w odniesieniu do wydajności lub niezawodności tych produktów.

Wyłączenie odpowiedzialności za kontakty z osobami trzecimi

Firma Microsoft udostępnia informacje kontaktowe innych firm, aby uzyskać dodatkowe informacje na temat tego tematu. Informacje te mogą zostać zmienione bez powiadomienia. Firma Microsoft nie gwarantuje dokładności informacji kontaktowych innych firm.