Udostępnij za pośrednictwem


Błąd nieprawidłowego poświadczenia przepływu pulpitu podczas korzystania z konta Microsoft Entra

Ten artykuł zawiera rozwiązanie kodu błędu lub WindowsIdentityIncorrect występującego InvalidConnectionCredentials podczas uruchamiania przepływu pulpitu przy użyciu konta Microsoft Entra.

Dotyczy: Power Automate
Oryginalny numer KB: 4555623

Symptomy

Po uruchomieniu przepływu pulpitu przy użyciu konta Microsoft Entra kończy się niepowodzeniem z kodem błędu InvalidConnectionCredentials lub WindowsIdentityIncorrect .

{
    "error":{
        "code": "InvalidConnectionCredentials",
        "message": "Could not connect to the Power Automate UI flows Agent. Please make sure that the UI flows connection credentials are valid."
    }    
}
{
    "error":{
        "code": "WindowsIdentityIncorrect",
        "message": "The credentials provided with the request are invalid."
    }    
}

Przyczyna

Może wystąpić błąd podczas korzystania z konta Microsoft Entra z kilku powodów:

  • Poświadczenia konta wprowadzone w połączeniu mogą nie być zgodne z poświadczeniami na maszynie.
  • Urządzenie może nie być przyłączone do firmy Microsoft lub dołączone hybrydowe rozwiązanie Microsoft Entra do obsługi uwierzytelniania firmy Microsoft Entra.
  • Konto Microsoft Entra może nie być zsynchronizowane z maszyną.

Rozwiązanie

  1. Upewnij się, że urządzenie jest przyłączone do firmy Microsoft lub przyłączone do domeny:

    1. Otwórz wiersz polecenia.

    2. Uruchom polecenie dsregcmd /status.

    3. Sprawdź sekcję Device State .

      Zrzut ekranu przedstawiający stan urządzenia w wierszu polecenia podczas uruchamiania polecenia dsregcmd /status.

      Upewnij się, że jedną z DomainJoined wartości lub AzureAdJoined jest YES.

      Jeśli tak nie jest, nie można użyć konta Microsoft Entra, chyba że urządzenie zostanie dołączone. Aby uzyskać więcej informacji, zobacz Jak dołączyć urządzenie.

  2. Zidentyfikuj konto Microsoft Entra do użycia w konfiguracji maszyny:

    1. Otwórz pozycję Ustawienia i wybierz pozycję Konta.

    2. Wybierz pozycję Uzyskaj dostęp do miejsca pracy lub nauki.

    3. Upewnij się, że widzisz tekst taki jak "Connected to <your_organization> Microsoft Entra ID". Konto, z którego jest połączony, może być używane w połączeniu.

  3. Zsynchronizuj konto Microsoft Entra na urządzeniu:

    1. Wybierz przycisk Informacje podczas wybierania połączenia Microsoft Entra na stronie Dostęp do miejsca pracy lub nauki.

    2. Spowoduje to otwarcie strony zawierającej informacje o połączeniu i stan synchronizacji urządzenia. Wybierz przycisk Synchronizuj na końcu strony i poczekaj na ukończenie tego procesu.

  4. Sprawdź, czy skonfigurowane konto Microsoft Entra może zalogować się na urządzeniu:

    1. Spróbuj zalogować się na maszynie przy użyciu konta Microsoft Entra zidentyfikowanego w kroku 2.
    2. Aby można było używać połączenia, logowanie urządzenia musi zakończyć się pomyślnie.
  5. Upewnij się, że przepływ jest prawidłowo skonfigurowany z odpowiednią nazwą użytkownika i hasłem. Musi to być zgodne z kontem na komputerze.

Więcej informacji