Udostępnij za pośrednictwem


Opcja "Odśwież wszystko" nie działa po wyeksportowaniu danych aplikacji do arkusza dynamicznego

Symptomy

Polecenie Eksportuj do programu Excel służy do eksportowania danych aplikacji do arkusza dynamicznego. Następnie otwórz pobrany plik i odśwież dane, wybierając pozycję Odśwież>wszystko. W takiej sytuacji okaże się, że dane znikają, a skoroszyt jest pusty. Może zostać wyświetlony następujący komunikat o błędzie:

To zapytanie sieci Web nie zwróciło żadnych danych. Aby zmienić zapytanie, kliknij przycisk OK, kliknij strzałkę w polu nazwy na pasku formuły, kliknij nazwę zewnętrznego zakresu danych dla kwerendy sieci Web, kliknij prawym przyciskiem myszy zaznaczenie, a następnie kliknij polecenie Edytuj zapytanie.

Zrzut ekranu przedstawiający zapytanie internetowe nie zwróciło żadnego błędu danych, który występuje po odświeżeniu wyeksportowanych danych aplikacji.

Przyczyna

Ten problem występuje, gdy dane, do których uzyskujesz dostęp, są chronione hasłem, a plik programu Excel nie może przesyłać haseł do zewnętrznych źródeł danych.

Rozwiązanie

Aby rozwiązać ten problem, należy edytować i zapisać kwerendę sieci Web.

  1. W pliku programu Excel wybierz pozycję Zapytania danych>i połączenia.

    Zrzut ekranu przedstawiający opcję Zapytania i połączenia na karcie Dane.

  2. W prawej części okna zostanie otwarte okienko Zapytania i połączenia. Na karcie Połączenia kliknij prawym przyciskiem myszy zapytanie, a następnie wybierz polecenie Właściwości.

    Zrzut ekranu przedstawiający ustawienia Właściwości zapytania w okienku Zapytania i połączenia.

  3. Zostanie otwarte okno Właściwości połączenia. Na karcie Definicja wybierz pozycję Edytuj zapytanie.

    Zrzut ekranu przedstawiający przycisk Edytuj zapytanie w okno Właściwości Połączenia.

  4. Jeśli zostanie wyświetlony monit, wprowadź nazwę użytkownika i hasło. Wprowadź dane tego samego użytkownika i hasło, których używasz do logowania się do aplikacji.

  5. W oknie Edytowanie zapytania internetowego wybierz pozycję Przejdź. Występuje komunikat o błędzie:

    Nie można ukończyć tej akcji

    Zrzut ekranu przedstawiający przycisk Przejdź w oknie Edytowanie zapytania internetowego.

  6. Zamknij okno Edytowania kwerendy sieciowej.

  7. To powinno rozwiązać problem. Odśwież dane w arkuszu ponownie, wybierając pozycję Odśwież wszystkie dane>.

    Zrzut ekranu przedstawiający sposób odświeżania danych aplikacji w programie Excel.

Jeśli powyższe kroki nie rozwiążą problemu, wykonaj następujące dodatkowe kroki:

  1. Wprowadź następujący link na pasku adresu okna Edytowanie zapytania internetowego, aby uzyskać dostęp do strony Ustawienia zaawansowane w usłudze Microsoft Dynamics 365 Customer Engagement. Pamiętaj, aby zastąpić OrgURL element adresem URL organizacji.

    https://OrgURL/main.aspx?settingsonly=true

  2. Wyloguj się przy użyciu linku opcji profilu w prawym górnym rogu, a następnie zaloguj się ponownie przy użyciu odpowiedniej tożsamości.

  3. Po zalogowaniu zamknij okno Edytowanie zapytania internetowego, a następnie w pliku programu Excel wybierz pozycję Odśwież wszystkie dane>. Dane zostaną odświeżone zgodnie z oczekiwaniami.

Zobacz też

Eksportowanie danych do arkusza dynamicznego programu Excel