Opcja "Odśwież wszystko" nie działa po wyeksportowaniu danych aplikacji do arkusza dynamicznego
Symptomy
Polecenie Eksportuj do programu Excel służy do eksportowania danych aplikacji do arkusza dynamicznego. Następnie otwórz pobrany plik i odśwież dane, wybierając pozycję Odśwież>wszystko. W takiej sytuacji okaże się, że dane znikają, a skoroszyt jest pusty. Może zostać wyświetlony następujący komunikat o błędzie:
To zapytanie sieci Web nie zwróciło żadnych danych. Aby zmienić zapytanie, kliknij przycisk OK, kliknij strzałkę w polu nazwy na pasku formuły, kliknij nazwę zewnętrznego zakresu danych dla kwerendy sieci Web, kliknij prawym przyciskiem myszy zaznaczenie, a następnie kliknij polecenie Edytuj zapytanie.
Przyczyna
Ten problem występuje, gdy dane, do których uzyskujesz dostęp, są chronione hasłem, a plik programu Excel nie może przesyłać haseł do zewnętrznych źródeł danych.
Rozwiązanie
Aby rozwiązać ten problem, należy edytować i zapisać kwerendę sieci Web.
W pliku programu Excel wybierz pozycję Zapytania danych>i połączenia.
W prawej części okna zostanie otwarte okienko Zapytania i połączenia. Na karcie Połączenia kliknij prawym przyciskiem myszy zapytanie, a następnie wybierz polecenie Właściwości.
Zostanie otwarte okno Właściwości połączenia. Na karcie Definicja wybierz pozycję Edytuj zapytanie.
Jeśli zostanie wyświetlony monit, wprowadź nazwę użytkownika i hasło. Wprowadź dane tego samego użytkownika i hasło, których używasz do logowania się do aplikacji.
W oknie Edytowanie zapytania internetowego wybierz pozycję Przejdź. Występuje komunikat o błędzie:
Nie można ukończyć tej akcji
Zamknij okno Edytowania kwerendy sieciowej.
To powinno rozwiązać problem. Odśwież dane w arkuszu ponownie, wybierając pozycję Odśwież wszystkie dane>.
Jeśli powyższe kroki nie rozwiążą problemu, wykonaj następujące dodatkowe kroki:
Wprowadź następujący link na pasku adresu okna Edytowanie zapytania internetowego, aby uzyskać dostęp do strony Ustawienia zaawansowane w usłudze Microsoft Dynamics 365 Customer Engagement. Pamiętaj, aby zastąpić
OrgURL
element adresem URL organizacji.https://OrgURL/main.aspx?settingsonly=true
Wyloguj się przy użyciu linku opcji profilu w prawym górnym rogu, a następnie zaloguj się ponownie przy użyciu odpowiedniej tożsamości.
Po zalogowaniu zamknij okno Edytowanie zapytania internetowego, a następnie w pliku programu Excel wybierz pozycję Odśwież wszystkie dane>. Dane zostaną odświeżone zgodnie z oczekiwaniami.