Udostępnij za pośrednictwem


Ustawienie wiadomości e-mail ochrony ustawień fabrycznych nie jest wymuszane po zresetowaniu urządzenia z systemem Android Enterprise

Ten artykuł zawiera rozwiązanie problemu polegającego na tym, że ustawienie wiadomości e-mail ochrony przed resetowaniem do ustawień fabrycznych nie działa zgodnie z oczekiwaniami dla zarejestrowanego urządzenia właściciela urządzenia z systemem Android Enterprise.

Symptomy

Rozważmy następujący scenariusz:

  • Masz urządzenie z systemem Android Enterprise zarejestrowane w usłudze Microsoft Intune.

  • Ustawienie Wiadomości e-mail ochrony ustawień fabrycznych jest włączone, a adres e-mail jest udostępniany, jak pokazano na poniższym zrzucie ekranu:

    Zrzut ekranu przedstawiający ustawienie wiadomości e-mail ochrony ustawień fabrycznych i przykładowy adres e-mail.

  • Resetowanie do ustawień fabrycznych na urządzeniu jest możliwe za pomocą menu Ustawienia (na przykład naciśnij pozycję Ustawienia>Ogólne zarządzanie>Resetuj>dane fabryczne) lub czyścisz urządzenie z usługi Intune w centrum administracyjnym usługi Microsoft Intune.

W tym scenariuszu możesz aktywować urządzenie przy użyciu konta Google, które nie jest uwzględnione w ustawieniu wiadomości e-mail ochrony przed resetowaniem do ustawień fabrycznych.

Przyczyna

To zachowanie jest oczekiwane. Po zresetowaniu do ustawień fabrycznych na urządzeniu za pomocą menu Ustawienia lub wyczyszczeniu urządzenia z usługi Intune w centrum administracyjnym usługi Microsoft Intune wszystkie dane zostaną usunięte. Obejmuje to dane ochrony przed resetowaniem do ustawień fabrycznych (FRP).

Rozwiązanie

Jedynym sposobem na zresetowanie do ustawień fabrycznych na urządzeniu bez utraty danych FRP jest tryb odzyskiwania.

Zalecamy ustawienie wartości Resetowanie do ustawień fabrycznych na Wartość Blokuj, aby uniemożliwić użytkownikom korzystanie z opcji resetowania do ustawień fabrycznych w ustawieniach urządzenia.

Zrzut ekranu przedstawiający opcje resetowania do ustawień fabrycznych.

Następnie użyj jednej z następujących metod podczas resetowania urządzenia do ustawień fabrycznych:

  • Zresetuj urządzenie za pomocą trybu odzyskiwania.
  • Wyczyść urządzenie z usługi Intune, gdy urządzenie znajduje się w Twoim posiadaniu i oczekuje się, że zostanie zresetowane do dalszego użycia.