Klienci programu Configuration Manager nie otrzymują aktualizacji oprogramowania
W tym artykule rozwiązano problem polegający na tym, że klienci programu Configuration Manager nie mogą pobierać aktualizacji z punktu aktualizacji oprogramowania.
Oryginalna wersja produktu: Configuration Manager (current branch — wersja 1702)
Oryginalny numer KB: 4041012
Objaw
Po zainstalowaniu programu Configuration Manager current branch w wersji 1702 mogą wystąpić następujące objawy:
- Nowo zainstalowani klienci nie mogą pobrać aktualizacji z punktu aktualizacji oprogramowania. Może się to również zdarzyć, jeśli punkt aktualizacji oprogramowania zostanie przeniesiony na inny serwer po zainstalowaniu wersji 1702. Po włączeniu pełnego rejestrowania klienta plik LocationServices.log zawiera pustą wartość wpisu
WSUSLocationReply
. - Niektóre komputery są wyświetlane w konsoli jako Nieznany stan.
Przyczyna
Począwszy od bieżącej gałęzi programu Configuration Manager w wersji 1702, klienci używają grup granic, aby znaleźć nowy punkt aktualizacji oprogramowania, oraz rezerwować i znajdować nowy punkt aktualizacji oprogramowania, jeśli ich bieżący punkt aktualizacji nie jest już dostępny. W przypadku zainstalowania nowej lokacji z wersją 1702 lub nowszą należy przypisać punkty aktualizacji oprogramowania do grupy granic, zanim klienci będą mogli je znaleźć i używać.
Rozwiązanie
Dodaj serwer z uruchomionym punktem aktualizacji oprogramowania do domyślnej grupy granic lokacji dla klientów. Poszczególne punkty aktualizacji oprogramowania można dodawać do różnych grup granic, aby kontrolować, które serwery klient może znaleźć. Aby uzyskać więcej informacji, zobacz punkty aktualizacji oprogramowania.
Aby dodać punkt aktualizacji oprogramowania do grupy granic, wykonaj następujące kroki:
- Utwórz grupę granic, jeśli nie istnieje, i dodaj wszystkie maszyny klienckie do grupy granic z punktem aktualizacji oprogramowania jako serwer lokacji.
- Uruchom cykl pobierania i oceny zasad komputera w programie Configuration Manager.
- Sprawdź LocationServices.log na komputerze klienckim, aby potwierdzić, że klient może nawiązać połączenie z serwerem usług Windows Server Update Services (WSUS).
Uwaga 16.
Po wykonaniu tej czynności może wystąpić pewne tymczasowe przekroczenia limitu czasu, jeśli duża liczba klientów próbuje nawiązać połączenie z serwerem WSUS. Może to również spowodować wysokie użycie procesora CPU na serwerze WSUS. Ponieważ klienci łączą użycie procesora CPU, powinny powrócić do normalnego. Jeśli wysokie użycie procesora CPU będzie się powtarzać po nawiązaniu połączenia ze wszystkimi klientami, zobacz Rozwiązywanie problemów z wysokim użyciem procesora CPU na serwerze WSUS.