Aplikacja mobilna Usługi Field Service wyświetla nieoczekiwanie stronę główną i nastąpi zresetowanie elementu WebView
Ten artykuł ułatwia rozwiązywanie problemów w aplikacji mobilnej usługi Dynamics 365 Field Service, gdzie strona główna jest nieoczekiwanie wyświetlana, a nastąpi zresetowanie widoku internetowego.
Symptomy
Aplikacja mobilna usługi Dynamics 365 Field Service nieoczekiwanie wyświetla stronę główną, a nastąpi zresetowanie widoku internetowego.
Przyczyna
Element WebView resetuje się z kilku powodów. Gdy na urządzeniu z systemem Android lub iOS jest mało pamięci, aktywnie zamyka aplikacje w celu odzyskania pamięci. Procesy korzystające z dużej ilości pamięci obejmują:
- Używanie aparatu i przekazywanie dużych plików, takich jak obrazy, wideo, audio, pliki PDF lub inne dokumenty.
- Dostosowania, takie jak kontrolki struktury składników usługi PowerApps (PCF). Na przykład używanie adnotacji z kontrolkami niestandardowymi.
- Ekran udostępniania w aplikacji Microsoft Teams.
- Uruchamianie innych aplikacji na urządzeniu.
Rozwiązanie
Spróbuj wykonać następujące sugestie, aby rozwiązać ten problem:
- Ustal przyczynę zresetowania. Użyj narzędzi deweloperskich, aby sprawdzić użycie pamięci w kontrolce WebView w aplikacji i przeglądarce. Na przykład debugowanie kodu JavaScript w aplikacji mobilnej w systemie Android lub Rozwiązywanie problemów z pamięcią.
- Wykonaj kroki, aby zmniejszyć użycie pamięci, takie jak unikanie udostępniania ekranu lub zamykania aplikacji innych niż aplikacja mobilna usługi Field Service, która używa dużej ilości pamięci.
- Zapoznaj się z zagadnieniami dotyczącymi wydajności podczas dostosowywania aplikacji mobilnej i podejmij działania w celu zmniejszenia użycia pamięci.