Panel komunikacji nie jest ładowany w wielokanałowej usłudze obsługi klienta
Ten artykuł zawiera rozwiązanie problemu polegającego na tym, że panel komunikacji nie jest ładowany w aplikacji Omnichannel for Customer Service.
Symptomy
Panel komunikacji nie jest ładowany w aplikacji Omnichannel for Customer Service.
Przyczyna
Panel nie jest ładowany, gdy:
- Rekord nie istnieje w aplikacji Platformy integracji kanału.
- Konfiguracje nie są synchronizowane.
Rozwiązanie
Aby rozwiązać ten problem:
Utwórz rekord Channel Integration Framework z poniższymi wartościami.
Pole Wartość Nazwa/nazwisko Obsługa wielokanałowa Etykieta Obsługa wielokanałowa Adres URL kanału <Adres URL> cdn kontrolki czatu?uci=true&env= <env>
&ocBaseUrl=oc endpoint>&ucilib=<<crm org url>/webresources/Widget/msdyn_ciLibrary.jsWłącz komunikację wychodzącą Nie Kolejność kanału 0 Wersja interfejsu API 1.0 Wybieranie aplikacji ujednoliconego interfejsu dla kanału Obsługa wielokanałowa dla Customer Service Wybieranie ról dla kanału - Obsługa wielokanałowa — Administrator
- Obsługa wielokanałowa - Agent
- Obsługa wielokanałowa - opiekun
Aby dowiedzieć się, jak utworzyć rekord, zobacz Konfiguruj dostawcę kanału dla organizacji Dynamics 365.
Aby zsynchronizować konfiguracje, usuń kanał i role, dodaj je ponownie i zapisz rekord.
- Zaloguj się w Dynamics 365.
- W obszarze Dynamics 365 wybierz przycisk rozwijany i wybierz Channel Integration Framework.
- Wybierz rekord Obsługa wielokanałowa z listy.
- Usuń Obsługa wielokanałowa dla Customer Service z sekcji Wybierz aplikacje ujednoliconego interfejsu dla kanału.
- Dodaj Obsługa wielokanałowa dla Customer Service ponownie w sekcji Wybierz aplikacje ujednoliconego interfejsu dla kanału.
- Usuń Obsługa wielokanałowa - Agent, Obsługa wielokanałowa - Opiekun i Obsługa wielokanałowa - Administrator z sekcji Wybierz role dla kanału.
- Dodaj Obsługa wielokanałowa - Agent, Obsługa wielokanałowa - Opiekun i Obsługa wielokanałowa - Administrator ponownie w sekcji Wybierz role dla kanału.
- Aby zapisać rekord wybierz Zapisz.
- Zaloguj się do aplikacji Omnichannel for Customer Service i sprawdź, czy panel komunikacji jest ładowany.