Błąd "Zadanie pozyskiwania usługi Delta Lake nie powiodło się"
Uwaga 16.
1 września 2023 r. scaliliśmy i zmieniliśmy nazwę usługi Dynamics 365 Marketing oraz Dynamics 365 Customer Insights. Dynamics 365 Marketing nosi teraz nazwę Dynamics 365 Customer Insights - Journeys. Dynamics 365 Customer Insights nosi teraz nazwę Dynamics 365 Customer Insights - Data. Aby uzyskać więcej informacji, zobacz często zadawane pytania Dynamics 365 Customer Insights.
Ten artykuł ułatwia rozwiązanie błędu "Zadanie pozyskiwania usługi Delta Lake nie powiodło się, aby uzyskać wersję", który może wystąpić podczas nawiązywania połączenia z danymi przechowywanymi w formacie delta w usłudze Microsoft Dynamics 365 Customer Insights — dane.
Symptomy
Źródło danych delta w usłudze Dynamics 365 Customer Insights — dane próbują nawiązać połączenie z tabelą korzystającą z funkcji wymagającej usługi Databricks minReaderVersion
lub nowszej 3
. W takim przypadku na stronie Źródła danych zostanie wyświetlony następujący komunikat o błędzie:
Zadanie pozyskiwania usługi Delta Lake nie może pobrać wersji <DataSourceId>.
Podczas wyświetlania kolumn w tabeli zostanie wyświetlony błąd "Nie można zapisać schematu źródła danych".
Przyczyna
Dynamics 365 Customer Insights — dane obsługują funkcje usługi Databricks z minReaderVersion
częścią 2
lub starszą. Funkcje usługi Databricks, które wymagają wersji 3
czytnika usługi Databricks lub nowszej, nie są obsługiwane.
Rozwiązanie
Aby rozwiązać ten problem, usuń funkcję z instalacji usługi Databricks i przywróć element minReaderVersion
na 2
. Aby uzyskać więcej informacji, zobacz Obsługiwane funkcje i wersje usługi Databricks.