Problemy z uprawnieniami w migracji do chmury Business Central
W tym artykule rozwiązano błędy uprawnień, które mogą wystąpić podczas próby skonfigurowania migracji do chmury w usłudze Business Central.
Symptomy
Gdy użytkownik uruchomi przewodnik konfiguracji asystowanej konfiguracji migracji do chmury, zostanie wyświetlony jeden z następujących komunikatów o błędach:
- Operacja docelowa NotifyBusinessCentral nie powiodła się: wywołanie działania sieci Web nie powiodło się z kodem HttpStatusCode — "500": Użytkownik konfigurując migrację do chmury nie ma wystarczających uprawnień: nie administrator delegowany lub administrator delegowany bez zgody klienta.
- Nie masz uprawnień do tworzenia ani uruchamiania zaplanowanych zadań.
Przyczyna
Użytkownik, który uruchamia konfigurację migracji do chmury, ma niewystarczające uprawnienia.
Rozwiązanie
Uwaga 16.
Aby rozwiązać ten problem, musisz mieć uprawnienia administratora w usłudze Business Central.
- Upewnij się, że użytkownik, na którym uruchomiono konfigurację , jest przypisany zestaw uprawnień SUPER w usłudze Business Central w trybie online.
- Jeśli użytkownik, na którym uruchomiono konfigurację, jest administratorem delegowanym, upewnij się, że klient wyraził zgodę.