Udostępnij za pośrednictwem


Rozwiązywanie problemów z wdrożeniem przy ponownym uruchamianiu lub zmienianiu rozmiaru istniejącej maszyny wirtualnej z systemem Windows na platformie Azure

Dotyczy: ✔️ maszyny wirtualne z systemem Windows

Podczas próby uruchomienia zatrzymanej maszyny wirtualnej platformy Azure lub zmiany rozmiaru istniejącej maszyny wirtualnej platformy Azure typowy błąd jest błędem alokacji. Ten błąd powoduje, że klaster lub region nie ma dostępnych zasobów lub nie może obsługiwać żądanego rozmiaru maszyny wirtualnej.

Jeśli problem z platformą Azure nie został rozwiązany w tym artykule, odwiedź fora platformy Azure w witrynach MSDN i Stack Overflow. Możesz opublikować swój problem na tych forach lub opublikować go na @AzureSupport na Twitterze. Możesz również przesłać żądanie pomoc techniczna platformy Azure. Aby przesłać wniosek o pomoc techniczną, na stronie pomoc techniczna platformy Azure wybierz pozycję Uzyskaj pomoc techniczną.

Zbieranie dzienników aktywności

Aby rozpocząć rozwiązywanie problemów, zbierz dzienniki aktywności, aby zidentyfikować błąd skojarzony z problemem. Poniższe linki zawierają szczegółowe informacje na temat procesu:

Wyświetlanie operacji wdrażania

Wyświetlanie dzienników aktywności w celu zarządzania zasobami platformy Azure

Problem: błąd podczas uruchamiania zatrzymanej maszyny wirtualnej

Spróbujesz uruchomić zatrzymaną maszynę wirtualną, ale wystąpi błąd alokacji.

Przyczyna

Próba wysłania żądania uruchomienia zatrzymanej maszyny wirtualnej musi zostać podjęta w oryginalnym klastrze, który hostuje usługę w chmurze. Jednak klaster nie ma dostępnego wolnego miejsca, aby spełnić żądanie.

Rozwiązanie

  • Zatrzymaj wszystkie maszyny wirtualne w zestawie dostępności, a następnie uruchom ponownie poszczególne maszyny wirtualne.

    1. Kliknij pozycję Grupy zasobów Grupy>zasobów Zasoby>>zestawu>dostępności Maszyny>wirtualne zatrzymaj maszynę wirtualną.>
    2. Po zatrzymaniu wszystkich maszyn wirtualnych wybierz każdą z zatrzymanych maszyn wirtualnych i kliknij przycisk Uruchom.
  • Ponów próbę ponownego uruchomienia żądania w późniejszym czasie.

Problem: błąd podczas zmiany rozmiaru istniejącej maszyny wirtualnej

Spróbujesz zmienić rozmiar istniejącej maszyny wirtualnej, ale wystąpi błąd alokacji.

Przyczyna

Próba wysłania żądania zmiany rozmiaru maszyny wirtualnej musi zostać podjęta w oryginalnym klastrze, który hostuje usługę w chmurze. Jednak klaster nie obsługuje żądanego rozmiaru maszyny wirtualnej.

Rozwiązanie

  • Ponów żądanie przy użyciu mniejszego rozmiaru maszyny wirtualnej.

  • Jeśli nie można zmienić rozmiaru żądanej maszyny wirtualnej:

    1. Zatrzymaj wszystkie maszyny wirtualne w zestawie dostępności.

      • Kliknij pozycję Grupy zasobów Grupy>zasobów Zasoby>>zestawu>dostępności Maszyny>wirtualne zatrzymaj maszynę wirtualną.>
    2. Po zatrzymaniu wszystkich maszyn wirtualnych zmień rozmiar odpowiedniej maszyny wirtualnej na większy.

    3. Wybierz zmienioną rozmiar maszyny wirtualnej i kliknij przycisk Start, a następnie uruchom każdą z zatrzymanych maszyn wirtualnych.

Błąd podczas zatrzymywania, uruchamiania, ponownego uruchamiania lub ponownego wdrażania istniejącej maszyny wirtualnej

Podczas próby zatrzymania, uruchomienia, ponownego uruchomienia lub ponownego wdrożenia istniejącej maszyny wirtualnej proces zakończy się niepowodzeniem i zostanie wyświetlony komunikat "Wystąpił nieoczekiwany błąd podczas przetwarzania profilu sieciowego maszyny wirtualnej. Ponów próbę później" komunikat o błędzie. W przypadku wystąpienia tego błędu maszyna wirtualna jest umieszczana w stanie niepowodzenia.

Przyczyna

Ten problem występuje, jeśli istnieje problem z przydzielaniem lub aktualizowaniem zasobów sieciowych.

Rozwiązanie

Spróbuj ponownie zastosować stan maszyny wirtualnej. Ta operacja ponownie uruchamia aprowizowanie maszyny wirtualnej i pomaga rozwiązać błąd stanu maszyny wirtualnej, który występuje, jeśli aprowizowanie maszyny wirtualnej nie powiodło się po uruchomieniu poprzedniej akcji maszyny wirtualnej.

  1. Przejdź do maszyny wirtualnej, która jest zablokowana w stanie niepowodzenia.
  2. W obszarze Pomoc wybierz pozycję Wdróż ponownie i ponownie zastosuj.
  3. Wybierz opcję Ponownie zastosuj.

Następne kroki

Jeśli podczas tworzenia nowej maszyny wirtualnej z systemem Windows na platformie Azure wystąpią problemy z wdrażaniem, zobacz Rozwiązywanie problemów z wdrażaniem podczas tworzenia nowej maszyny wirtualnej z systemem Windows na platformie Azure.

Skontaktuj się z nami, aby uzyskać pomoc

Jeśli masz pytania lub potrzebujesz pomocy, utwórz wniosek o pomoc techniczną lub zadaj pytanie w społeczności wsparcia dla platformy Azure. Możesz również przesłać opinię o produkcie do społeczności opinii na temat platformy Azure.