Błąd podczas próby uaktualnienia agenta MARS: aktualizacja agenta usług Microsoft Azure Recovery Services nie powiodła się
W tym artykule opisano objawy i rozwiązanie problemu występującego podczas próby uaktualnienia ze starszej wersji do nowszej wersji lub wydania agenta usług Microsoft Azure Recovery Services (MARS).
Oryginalna wersja produktu: Azure Site Recovery
Oryginalny numer KB: 4020490
Symptomy
Podczas próby uaktualnienia agenta MARS przy użyciu Kreatora uaktualniania agenta usług Microsoft Azure Recovery Services uaktualnienie kończy się niepowodzeniem i zostanie wyświetlony następujący komunikat o błędzie:
Aktualizacja agenta usługi Microsoft Azure Recovery Service nie powiodła się.
Błąd: Nie można uruchomić usługi RecoveryServicesManagementAgent. Odinstalowywanie poprawki
Problem: Instalacja aktualizacji nie powiodła się z powodu błędu 1612
Przyczyna
Ten problem występuje, ponieważ uaktualnienie nie może odnaleźć instalatora źródłowego agenta MARS w pamięci podręcznej Instalatora Windows. Aby uaktualnienie zostało ukończone pomyślnie, instalator źródłowy jest wymagany.
Rozwiązanie
Aby rozwiązać ten problem, upewnij się, że instalator źródłowy istnieje w pamięci podręcznej Instalatora Windows. W tym celu wykonaj następujące kroki:
Zamknij Kreatora uaktualniania agenta usług Microsoft Azure Recovery Services.
Otwórz plik OBPatch.log, który znajduje się w folderze
C:\Windows\Temp
.Znajdź wiersz error-description w pliku OBPatch.log wyszukiwania "Ostrzeżenie: lokalny pakiet buforowany".
Znajdź wiersz podobny do następującego: Ostrzeżenie:
Brak lokalnego buforowanego pakietu "C:\Windows\Installer\Unique_ID.msi.
Uwaga theUnique_IDvalue na potrzeby przyszłego dokumentacji.
Kliknij dwukrotnie plik instalatora aktualizacji agenta MARS (.exe). Spowoduje to skopiowanie wszystkich plików binarnych i plików instalatora związanych z instalacją do lokalizacji tymczasowej na komputerze i otwarcie Kreatora uaktualniania agenta usługi Microsoft Azure Recovery Services.
Uwaga Pozostaw kreatora otwarty do kroku 12.
Otwórz plik OBInstaller0Curr.errlog znajdujący się w folderze "C:\Windows\Temp".
Wyszukaj w tekście ciąg "Ścieżka katalogu dla ekranu SetupLaunchScreen", a następnie znajdź wiersz z najnowszą sygnaturą czasową podobną do następującej: Ścieżka katalogu setupLaunchScreen:
C:\Temp_ID
.Przejdź do folderu
C:\Temp_ID\Installers
.W tym folderze znajdź i skopiuj plik OBSAGENT.msi do folderu C:\Windows\Installer. Zmień nazwę pliku docelowego na Unique_ID.msi.
Zamknij Kreatora uaktualniania agenta MARS.
Uruchom instalatora uaktualnienia, aby zainstalować uaktualnienie. Jeśli problem będzie się powtarzać, skontaktuj się z pomoc techniczna firmy Microsoft.
Skontaktuj się z nami, aby uzyskać pomoc
Jeśli masz pytania lub potrzebujesz pomocy, utwórz wniosek o pomoc techniczną lub zadaj pytanie w społeczności wsparcia dla platformy Azure. Możesz również przesłać opinię o produkcie do społeczności opinii na temat platformy Azure.