Dodatek integracji z pakietem Office programu Team Foundation Server nie jest uruchamiany
Ten artykuł ułatwia rozwiązanie błędu, który występuje, gdy dodatek pakietu Office Team Foundation Server 2015 nie działa.
Oryginalna wersja produktu: Team Foundation Server
Oryginalny numer KB: 3192409
Symptomy
Okazuje się, że dodatek pakietu Office Team Foundation Server 2015 nie działa, ponieważ nie jest podpisany przez zaufanego wydawcę. Ten problem występuje, gdy spełnione są następujące warunki:
Korzystasz z 32-bitowej wersji pakietu Office na komputerze 64-bitowym.
Masz wersję serwera Team Foundation Server starszą niż Team Foundation Server 2015 Update 3.
W ustawieniach pakietu Office pole wyboru Wymagane dodatki aplikacji do podpisania przez zaufanego wydawcę jest zaznaczone w obszarze Plik -Opcje ->>Centrum zaufania ->Opcje.
Przyczyna
Ten problem występuje, jeśli w polu Lokalizacja dodatku znajdują się znaki cudzysłowu. Uniemożliwia to pakietowi Office weryfikowanie wydawcy. Aby potwierdzić, że jest to przyczyna problemu, przejdź do pozycji Plik ->Opcje ->Dodatki, wybierz dodatek Team Foundation, a następnie wyświetl pole Lokalizacja, aby sprawdzić, czy ścieżka lokalizacji znajduje się wewnątrz cudzysłowów.
Rozwiązanie
Rozwiązanie tego problemu jest zawarte w programie Team Foundation Server 2015 Update 3 i nowszych wersjach serwera Team Foundation Server. Rozważ zaktualizowanie do aktualizacji Update 3, aby rozwiązać ten problem.
Jeśli masz wcześniejszą kompilację, możesz usunąć znaki cudzysłowu z odpowiedniego klucza rejestru. Przed edytowaniem klucza rejestru upewnij się, że utworzono kopię zapasową.
W tym celu możesz użyć pliku skryptu .reg lub ręcznie edytować ciąg w Redaktor rejestru. Aby ręcznie edytować ciąg, wykonaj następujące kroki:
Kliknij przycisk Start, kliknij przycisk Uruchom, a następnie wpisz regedit.
Przejdź do następującego podklucza serwera Team Foundation Server 2015:
[HKEY_CLASSES_ROOT\WOW6432Node\CLSID\{04986E13-556D-463F-ADBD-9D8CAD03707B}\InprocServer32]
Kliknij prawym przyciskiem myszy wpis (domyślny), kliknij przycisk Modyfikuj, a następnie usuń cudzysłów na początku i na końcu wartości w kolumnie Dane .
Więcej informacji
Jeśli po usunięciu cudzysłowów nadal występują błędy, upewnij się, że firma Microsoft Corporation jest wymieniona jako zaufany wydawca na komputerze. Jeśli tak nie jest, musisz zainstalować certyfikat firmy Microsoft.
Skontaktuj się z nami, aby uzyskać pomoc
Jeśli masz pytania lub potrzebujesz pomocy, utwórz wniosek o pomoc techniczną lub zadaj pytanie w społeczności wsparcia dla platformy Azure. Możesz również przesłać opinię o produkcie do społeczności opinii platformy Azure.