Udostępnij za pośrednictwem


Brak miejsca na dysku E lub F

W tym artykule omówiono sposób rozwiązywania scenariusza, w którym zabraknie wolnego miejsca na dysku E lub F w usługach Microsoft Azure Cloud Services.

Symptomy

Hostujesz wystąpienie usług Cloud Services, ale odkrywasz, że dysk E lub F ma zero wolnego miejsca.

Przyczyna

Ponieważ dyski E i F są używane jako dysk aplikacji, żadne dane związane z aplikacją nie powinny być przechowywane na tych dyskach. Magazyn danych może spowodować, że użycie miejsca będzie znacznie większe niż suma poszczególnych rozmiarów plików. Aby uzyskać więcej informacji, zobacz Gdzie poszedł mój obszar?.

Używane miejsce do magazynowania nie powinno mieć wpływu na działanie aplikacji. Po utworzeniu dysków maszyny wirtualne platformy Azure nie zapisują do nich, chyba że kod aplikacji nie zostanie utworzony. Kod aplikacji nie powinien być zapisywany na tych dyskach, mimo to.

Rozwiązanie

W przypadku danych, do których aplikacja musi odczytywać dane i zapisywać je, zalecamy użycie zewnętrznej usługi magazynu, takiej jak Azure Storage lub Azure SQL Server.

Jeśli wymagana jest lokalizacja lokalnego magazynu danych, upewnij się, że kod aplikacji używa zasobów magazynu lokalnego. Są one przechowywane na dysku lokalnym C. Aby uzyskać więcej informacji, zobacz Konfigurowanie zasobów magazynu lokalnego i partycji dysku platformy Azure.

Zastrzeżenie dotyczące innych firm

Produkty innych firm omówione w tym artykule są wytwarzane przez producentów niezależnych od firmy Microsoft. Firma Microsoft nie udziela żadnych gwarancji, dorozumianych ani żadnego innego rodzaju, w odniesieniu do wydajności lub niezawodności tych produktów.

Skontaktuj się z nami, aby uzyskać pomoc

Jeśli masz pytania lub potrzebujesz pomocy, utwórz wniosek o pomoc techniczną lub zadaj pytanie w społeczności wsparcia dla platformy Azure. Możesz również przesłać opinię o produkcie do społeczności opinii na temat platformy Azure.