Rozwiązywanie problemów z wyjątkami progu recyklingu roli usługi w chmurze (wersja klasyczna)
Ważne
Usługi Cloud Services (wersja klasyczna) są teraz przestarzałe dla nowych klientów i zostaną wycofane 31 sierpnia 2024 r. dla wszystkich klientów. Nowe wdrożenia powinny używać nowego modelu wdrażania opartego na usłudze Azure Resource Manager, azure Cloud Services (rozszerzona obsługa).
Ten artykuł ułatwia rozwiązywanie problemów z wyjątkami UpdateDeploymentRoleRecycleThresholdReached występującymi podczas wdrażania usług w chmurze.
Objaw
Wystąpienia roli usługi są stale odzyskiwanych podczas aktualizacji lub uaktualniania. Aktualizacja lub uaktualnienie z ustawieniami konfiguracji uniemożliwiły uruchamianie wystąpień ról.
Zostanie wyświetlony następujący komunikat:
Wystąpienia ról zostały poddane odreagowowieniu kilka razy podczas operacji aktualizacji lub uaktualniania. Oznacza to, że nowa wersja usługi lub ustawienia konfiguracji podane podczas konfigurowania usługi uniemożliwiają uruchamianie wystąpień ról. Sprawdź, czy kod nie zgłasza nieobsługiwane wyjątki i czy ustawienia konfiguracji są poprawne, a następnie uruchom kolejną operację aktualizacji lub uaktualnienia.
Przyczyna
Wyjątek UpdateDeploymentRoleRecycleThresholdReached oznacza, że wystąpienia ról usługi w chmurze zostały od jakiegoś czasu recyklingu.
Aby uzyskać więcej informacji na temat nieobsługiwanych wyjątków ról, zobacz Typowe problemy, które powodują odtwarzanie ról usługi Azure Cloud Service (klasycznej).
Rozwiązanie
Aby rozwiązać ten problem, wykonaj jedną z następujących czynności:
Usuń miejsce wdrożenia , z którego są odzyskiwalne role. Następnie wykonaj nowe wdrożenie w pustym miejscu.
Utwórz nowe wystąpienie usługi w chmurze, wdróż je i zaktualizuj nazwę kanoniczną usługi (CName).
Co zrobić, jeśli nie chcesz utracić adresu IP skojarzonego z istniejącym miejscem wdrożenia? Następnie wykonaj następujące kroki, aby zarezerwować i zwolnić adres. Aby uzyskać więcej informacji, zobacz Zastrzeżone adresy IP dla usług w chmurze i maszyn wirtualnych.
Zarezerwuj adres IP istniejącego miejsca wdrożenia.
Zwolnij skojarzony zastrzeżony adres IP.
Usuń miejsce wdrożenia.
Utwórz nowe wdrożenie w tym miejscu.
Skojarz wymagany zastrzeżony adres IP z tym miejscem usługi w chmurze.
Skontaktuj się z nami, aby uzyskać pomoc
Jeśli masz pytania lub potrzebujesz pomocy, utwórz wniosek o pomoc techniczną lub zadaj pytanie w społeczności wsparcia dla platformy Azure. Możesz również przesłać opinię o produkcie do społeczności opinii na temat platformy Azure.