System Windows nie może uruchomić programu Microsoft Monitoring Agent
Uwaga 16.
Agent usługi Log Analytics, znany również jako Microsoft Monitoring Agent (MMA), zostanie wycofany w sierpniu 2024 roku. W związku z tym plany usługi Defender for Servers i Defender for SQL server na maszynach w Microsoft Defender dla Chmury zostaną zaktualizowane, a funkcje, które korzystają z agenta usługi Log Analytics, zostaną przeprojektowane. Aby uzyskać więcej informacji, zobacz Przygotowanie do wycofania agenta usługi Log Analytics.
Ten artykuł ułatwia rozwiązywanie problemów ze scenariuszem, w którym system Windows nie uruchamia programu Microsoft Monitoring Agent (agenta usługi Log Analytics dla systemu Windows) na komputerze lokalnym. W przypadku wystąpienia tego problemu zostanie wyświetlony komunikat o błędzie "Usługa Microsoft Monitoring Agent została zakończona z powodu błędu specyficznego dla usługi Odmowa dostępu".
Wymagania wstępne
- Narzędzie Monitor procesów
Symptomy
Po otwarciu przystawki Usługi (services.msc), aby spróbować uruchomić usługę Microsoft Monitoring Agent , zostanie wyświetlone okno dialogowe i zostanie wyświetlony następujący komunikat o błędzie:
System Windows nie może uruchomić programu Microsoft Monitoring Agent na komputerze lokalnym. Aby uzyskać więcej informacji, zapoznaj się z dziennikem zdarzeń systemu. Jeśli jest to usługa firmy innej niż Microsoft, skontaktuj się z dostawcą usługi i zapoznaj się z kodem błędu specyficznym dla usługi 5.
W przystawce Podgląd zdarzeń (eventvwr.msc) odpowiedni dziennik zdarzeń systemu zawiera wpis błędu "Odmowa dostępu":
Log Name: System
Source: Service Control Manager
Date: 8/19/2021 3:03:27 PM
Event ID: 7024
Task Category: None
Level: Error
Keywords: Classic
User: N/A
Computer: ContosoServer2k8R2
Description:
The Microsoft Monitoring Agent service terminated with service-specific error Access is denied.
Przyczyna
Rejestr odmawia dostępu do odczytu/zapisu z programu Microsoft Monitoring Agent do parametru SecureStorageManager . Aby sprawdzić ten scenariusz, wykonaj następujące kroki po pojawieniu się komunikatu o błędzie "Odmowa dostępu":
Otwórz monitor procesu.
Wyszukaj wpis, który ma następujące wartości:
Kolumna Wartość Nazwa procesu HealthService.exe Operacja RegOpenKey Ścieżka HKLM\SYSTEM\CurrentControlSet\Services\HealthService\Parameters\SecureStorageManager Result ODMOWA DOSTĘPU Szczegół Żądany dostęp: odczyt/zapis Wybierz pozycję Start, wprowadź ciąg regedit, a następnie wybierz pozycję Edytor rejestru.
W Edytorze rejestru wybierz menu Widok . Jeśli obok paska adresu nie ma znacznika wyboru, wybierz ten element menu.
Na pasku adresu (poniżej menu i powyżej okienka nawigacji) usuń istniejący tekst, wprowadź HKLM \SYSTEM\CurrentControlSet\Services\HealthService\Parameters\SecureStorageManager, a następnie naciśnij Enter.
W menu wybierz pozycję Edytuj>uprawnienia.
W oknie dialogowym Uprawnienia dla programu SecureStorageManager upewnij się, że w polu Nazwy grupy lub użytkowników są wyświetlane wpisy dla systemu i administratorów (<ComputerName>). Dla każdego z tych wpisów sprawdź wiersz Pełna kontrola w polu Uprawnienia dla< GroupOrUserName>, aby sprawdzić, czy wybrano kolumnę Zezwalaj.
Czy pełna kontrola nie jest jawnie dozwolona dla użytkownika systemowego lub grupy administratorów? Jeśli tak jest, ktoś zmienił uprawnienia domyślne. Ze względu na tę zmianę program Microsoft Monitoring Agent nie ma już uprawnień dostępu do parametru SecureStorageManager .
Jeśli spełnione są następujące warunki, można zmienić uprawnienia domyślne:
Serwer jest wzmocniony.
Użytkownik, aplikacja lub skrypt modyfikuje domyślne uprawnienia do mniejszego niż poziom odczytu/zapisu w rejestrze.
Rozwiązanie
Przywróć pełną kontrolę do parametru SecureStorageManager dla użytkownika systemowego i administratorów. W tym celu wykonaj następujące kroki:
Ostrzeżenie
Niepoprawne zmodyfikowanie rejestru przy użyciu Edytora rejestru lub innej metody może stać się przyczyną poważnych problemów. Ich rozwiązanie może wymagać ponownego zainstalowania systemu operacyjnego. Firma Microsoft nie może zagwarantować, że rozwiązanie tych problemów będzie możliwe. Rejestr można modyfikować na własną odpowiedzialność.
(Zalecane) Tworzenie kopii zapasowej rejestru.
Wróć do edytora rejestru lub otwórz go ponownie.
Na pasku adresu wprowadź ponownie ścieżkę rejestru dla parametru SecureStorageManager (HKLM\SYSTEM\CurrentControlSet\Services\HealthService\Parameters\SecureStorageManager), a następnie naciśnij Enter.
Wybierz pozycję Edytuj>uprawnienia, a następnie ponownie zastosuj domyślne uprawnienie w obszarze Pełna kontrola (Zezwalaj) dla użytkownika SYSTEM i grupy Administratorzy (<ComputerName).>
Skontaktuj się z nami, aby uzyskać pomoc
Jeśli masz pytania lub potrzebujesz pomocy, utwórz wniosek o pomoc techniczną lub zadaj pytanie w społeczności wsparcia dla platformy Azure. Możesz również przesłać opinię o produkcie do społeczności opinii na temat platformy Azure.