Uaktualnianie klastra usługi AKS kończy się niepowodzeniem z powodu reguł sieciowej grupy zabezpieczeń
W tym artykule omówiono sposób rozwiązywania problemów, jeśli uaktualnianie klastra usługi Azure Kubernetes Service (AKS) kończy się niepowodzeniem z powodu reguł sieciowej grupy zabezpieczeń.
Wymagania wstępne
Ten artykuł wymaga interfejsu wiersza polecenia platformy Azure w wersji 2.0.65 lub nowszej. Aby znaleźć numer wersji, uruchom polecenie az --version
. Jeśli musisz zainstalować lub uaktualnić interfejs wiersza polecenia platformy Azure, zobacz Jak zainstalować interfejs wiersza polecenia platformy Azure.
Aby uzyskać bardziej szczegółowe informacje na temat procesu uaktualniania, zobacz sekcję "Uaktualnianie klastra AKS" w temacie Uaktualnianie klastra usługi Azure Kubernetes Service (AKS).
Symptomy
Uaktualnianie klastra usługi AKS kończy się niepowodzeniem i zostanie wyświetlony komunikat o błędzie wskazujący, że jest zaangażowana reguła sieciowej grupy zabezpieczeń.
Przyczyna
Reguła sieciowej grupy zabezpieczeń blokuje pobieranie wymaganych zasobów przez klaster.
Rozwiązanie
Aby rozwiązać ten problem, wykonaj poniższe czynności:
Uruchom polecenie
az network nsg list -o table
, a następnie znajdź sieciową grupę zabezpieczeń połączoną z klastrem. Sieciowa grupa zabezpieczeń znajduje się w grupie zasobów o nazwieMC_<RG name>_<your AKS cluster name>
.Uruchom następujące polecenie, aby wyświetlić reguły sieciowej grupy zabezpieczeń:
az network nsg rule list --resource-group <Rg name> --nsg-name <nsg name> --include-default -o table
Poniższy zrzut ekranu przedstawia reguły domyślne.
Jeśli masz reguły domyślne, pomiń ten krok. W przeciwnym razie popraw i usuń reguły blokujące ruch internetowy. Następnie uruchom następujące polecenie, aby uaktualnić klaster usługi AKS do tej samej wersji, do której wcześniej próbowano przeprowadzić uaktualnienie. Ten proces spowoduje wyzwolenie uzgodnień.
az aks upgrade --resource-group <ResourceGroupName> --name <AKSClusterName> --kubernetes-version <KUBERNETES_VERSION>
Skontaktuj się z nami, aby uzyskać pomoc
Jeśli masz pytania lub potrzebujesz pomocy, utwórz wniosek o pomoc techniczną lub zadaj pytanie w społeczności wsparcia dla platformy Azure. Możesz również przesłać opinię o produkcie do społeczności opinii na temat platformy Azure.