Rozwiązywanie problemów z kodem błędu InUseRouteTableCannotBeDeleted
W tym artykule omówiono sposób identyfikowania i rozwiązywania błędu występującego InUseRouteTableCannotBeDeleted
podczas próby usunięcia klastra usługi Microsoft Azure Kubernetes Service (AKS).
Symptomy
Podczas próby usunięcia klastra usługi AKS zostanie wyświetlony następujący komunikat o błędzie:
Kod błędu „InUseRouteTableCannotBeDeleted”
{
„Tabela routingu aks-agentpool-routetable jest używana i nie można jej usunąć. ...../providers/Microsoft.Network/routeTables/aks-agentpool-test-routetable”
}
Przyczyna
Próbowano usunąć klaster usługi AKS, gdy skojarzona z nią tabela tras była nadal używana.
Rozwiązanie
Usuń skojarzoną podsieć w tabeli routingu. Aby uzyskać instrukcje, zobacz Usuwanie skojarzenia tabeli tras z podsieci. Następnie spróbuj ponownie usunąć klaster usługi AKS.
Skontaktuj się z nami, aby uzyskać pomoc
Jeśli masz pytania lub potrzebujesz pomocy, utwórz wniosek o pomoc techniczną lub zadaj pytanie w społeczności wsparcia dla platformy Azure. Możesz również przesłać opinię o produkcie do społeczności opinii na temat platformy Azure.