Pule węzłów systemu Windows Server nie zostały uaktualnione do wersji Gen2 podczas uaktualniania obrazu węzła klastra
W tym artykule omówiono sposób rozwiązywania problemów ze scenariuszem, w którym pule węzłów systemu Windows Server nie są automatycznie uaktualniane z maszyn wirtualnych Gen1 do Gen2, gdy obraz węzła klastra jest uaktualniany w usłudze Microsoft Azure Kubernetes Service (AKS).
Uwaga 16.
Ten scenariusz nie ma zastosowania do maszyn wirtualnych gen2 w pulach węzłów systemu Linux.
Wymagania wstępne
Symptomy
Istniejące pule węzłów systemu Windows Server nie są uaktualniane z gen1 do gen2 podczas uaktualniania obrazu węzła przy użyciu jednej z następujących metod w interfejsie wiersza polecenia platformy Azure:
Całe uaktualnienie klastra (przy użyciu polecenia az aks upgrade )
Określone uaktualnienie puli węzłów (za pomocą polecenia az aks nodepool upgrade )
Przyczyna
Przyczyna 1. Istniejące pule węzłów nie są automatycznie uaktualniane do maszyn wirtualnych gen2
Zgodnie z projektem uaktualnienie obrazu węzła nie obsługuje aktualizowania ani uaktualniania istniejących puli węzłów. Polecenia az aks upgrade
i az aks nodepool upgrade
uaktualniają tylko obraz węzła (do nowszej wersji obrazu węzła). Te polecenia nie uaktualniają odpowiedniej generacji maszyny wirtualnej.
Przyczyna 2. Uaktualnienie klastra do platformy Kubernetes w wersji 1.25 lub nowszej powoduje uaktualnienie tylko systemu operacyjnego
Uaktualnienie klastra do platformy Kubernetes w wersji 1.25 lub nowszej spowoduje uaktualnienie tylko systemu operacyjnego (do systemu operacyjnego Windows Server 2022). Nie ma to wpływu na istniejące pule węzłów. Skojarzony zestaw skalowania maszyn wirtualnych będzie zawierać maszyny wirtualne, które mają tę samą maszynę wirtualną Gen1.
Przyczyna 3: Uaktualniono klaster i nową pulę węzłów utworzoną przy użyciu systemu Windows Server 2022 bez określania prawidłowego rozmiaru maszyny wirtualnej
Po uaktualnieniu klastra do platformy Kubernetes w wersji 1.25 lub nowszej należy określić system operacyjny Windows Server 2022 jako system operacyjny do użycia na maszynach wirtualnych puli węzłów. Jednak maszyny wirtualne nie używają odwołania do obrazu węzła Gen2 z jednego z następujących powodów:
Nie określasz rozmiaru maszyny wirtualnej, a domyślny rozmiar maszyny wirtualnej w regionie nie obsługuje maszyn wirtualnych gen2.
Należy określić rozmiar maszyny wirtualnej tylko dla 1. generacji.
Po uaktualnieniu domyślnego systemu operacyjnego z systemu Windows Server 2019 (Windows2019
) do systemu Windows Server 2022 (Windows2022
) istniejące pule węzłów nie są automatycznie uaktualniane do innej generacji maszyn wirtualnych.
Rozwiązanie
Uaktualnij klaster, a następnie utwórz nową pulę węzłów systemu Windows Server, która obsługuje rozmiary maszyn wirtualnych gen2 w tym klastrze zgodnie z poniższymi wytycznymi.
Wersja uaktualnienia klastra Kubernetes | Wskazówki dotyczące tworzenia klastra |
---|---|
1.25 lub nowsza wersja | Po uruchomieniu polecenia az aks create w celu utworzenia klastra ustaw parametr na --node-vm-size rozmiar maszyny wirtualnej Gen2. |
Starsza wersja niż 1.25 | Po uruchomieniu polecenia az aks create w celu utworzenia klastra ustaw --os-sku wartość parametru na Windows2022 , a następnie ustaw wartość parametru --node-vm-size na rozmiar maszyny wirtualnej Gen2. |
Uwaga 16.
Jeśli określisz rozmiar maszyny wirtualnej Gen2 i system operacyjny jako Windows Server 2019, zostanie wyświetlony ErrorCode_Windows2019NotSupportedWithGen2VM
kod błędu, któremu towarzyszy następujący komunikat o błędzie:
<rozmiar> maszyny wirtualnej to maszyna wirtualna tylko dla 2. generacji. System Windows2019 nie obsługuje maszyn wirtualnych 2. generacji. Można jednak wybrać rozmiar maszyny wirtualnej 1. generacji lub ustawić os_sku na 2022.
Aby uniknąć tego problemu, wybierz jedną z następujących opcji podczas tworzenia klastra:
Wybierz rozmiar maszyny wirtualnej Gen1 do użycia razem z systemem Windows Server 2019.
Ustaw jednostkę SKU systemu operacyjnego na windows Server 2022 do użycia razem z maszyną wirtualną Gen2.
Skontaktuj się z nami, aby uzyskać pomoc
Jeśli masz pytania lub potrzebujesz pomocy, utwórz wniosek o pomoc techniczną lub zadaj pytanie w społeczności wsparcia dla platformy Azure. Możesz również przesłać opinię o produkcie do społeczności opinii na temat platformy Azure.