Rozwiązywanie problemów z kodem błędu ERR_VHD_FILE_NOT_FOUND (124)
W tym artykule omówiono sposób identyfikowania i rozwiązywania ERR_VHD_FILE_NOT_FOUND
kodu błędu (kod błędu nr 124), który występuje podczas próby utworzenia i wdrożenia klastra usługi Microsoft Azure Kubernetes Service (AKS).
Symptomy
Podczas próby utworzenia klastra usługi AKS zostanie wyświetlony następujący komunikat o błędzie:
VMExtensionProvisioningError: maszyna wirtualna zgłosiła błąd podczas przetwarzania rozszerzenia "vmssCSE".
Komunikat o błędzie: "Enable failed: failed to execute command: command terminated with exit status=124 (Włączanie nie powiodło się: nie można wykonać polecenia: polecenie zostało zakończone ze stanem zakończenia=124)
Przyczyna
W rzadkich okolicznościach kod zakończenia 124 dla niestandardowego rozszerzenia skryptu zestawu skalowania maszyn wirtualnych platformy Azure (vmssCSE
) może wystąpić zamiast następujących kodów błędów:
Nazwa kodu błędu | Numer kodu błędu |
---|---|
OutboundConnFailVMExtensionError |
50 |
K8SAPIServerConnFailVMExtensionError |
51 |
K8SAPIServerDNSLookupFailVMExtensionError |
52 |
Ten błąd występuje, jeśli występuje problem z łącznością między klastrem usługi AKS i wymaganymi punktami końcowymi platformy Azure, takimi jak mcr.microsoft.com
lub acs-mirror.azureedge.net
.
Rozwiązanie
Przejrzyj reguły sieci wychodzącej i nazwy FQDN dla klastrów usługi Azure Kubernetes Service (AKS) i upewnij się, że wszystkie usługi interfejsu API są dozwolone.
Aby uzyskać szczegółowe instrukcje rozwiązywania problemów, zapoznaj się z przewodnikami rozwiązywania problemów w następujących artykułach:
Rozwiązywanie problemów z kodem błędu OutboundConnFailVMExtensionError (50)
Rozwiązywanie problemów z kodem błędu K8SAPIServerConnFailVMExtensionError (51)
Rozwiązywanie problemów z kodem błędu K8SAPIServerDNSLookupFailVMExtensionError (52)
Informacje
Ogólne rozwiązywanie problemów z tworzeniem klastra usługi AKS
Reguły sieci wychodzącej i nazwy FQDN dla klastrów usługi Azure Kubernetes Service (AKS)
Skontaktuj się z nami, aby uzyskać pomoc
Jeśli masz pytania lub potrzebujesz pomocy, utwórz wniosek o pomoc techniczną lub zadaj pytanie w społeczności wsparcia dla platformy Azure. Możesz również przesłać opinię o produkcie do społeczności opinii na temat platformy Azure.