Udostępnij za pośrednictwem


Rozwiązywanie problemów z kodem błędu TooManyRequestsReceived lub SubscriptionRequestsThrottled

W tym artykule omówiono sposób identyfikowania i usuwania błędu lub SubscriptionRequestsThrottled występującego TooManyRequestsReceived podczas próby usunięcia klastra usługi Microsoft Azure Kubernetes Service (AKS).

Symptomy

Podczas próby usunięcia klastra usługi AKS zostanie wyświetlony następujący komunikat o błędzie:

internalErrorCode: TooManyRequestsReceived

StatusCode: 429

{

komunikat: "Liczba żądań odczytu dla subskrypcji "....." przekroczono limit wartości "...". dla przedziału czasu "XX:XX:XX". Spróbuj ponownie po ..... sekundy".

}

Przyczyna

Każda operacja na poziomie subskrypcji i na poziomie dzierżawy podlega limitom ograniczania przepustowości. Te limity dotyczą każdego wystąpienia usługi Azure Resource Manager. Po osiągnięciu limitu otrzymasz odpowiedź HTTP wskazującą kod stanu 429: "Zbyt wiele żądań".

Rozwiązanie

Odpowiedź HTTP zawiera Retry-After wartość. Określa liczbę sekund oczekiwania (lub uśpienia) aplikacji przed wysłaniem następnego żądania. Jeśli wyślesz żądanie przed upływem wartości ponawiania próby, żądanie nie zostanie przetworzone i zostanie zwrócona nowa wartość ponawiania. Aby uzyskać więcej informacji na temat limitów ograniczania przepustowości, zobacz Ograniczanie żądań usługi Resource Manager.

Skontaktuj się z nami, aby uzyskać pomoc

Jeśli masz pytania lub potrzebujesz pomocy, utwórz wniosek o pomoc techniczną lub zadaj pytanie w społeczności wsparcia dla platformy Azure. Możesz również przesłać opinię o produkcie do społeczności opinii na temat platformy Azure.