Usługa Azure Container Instances pokazuje nieoczekiwane metryki użycia pamięci
W tym artykule omówiono scenariusze, w których wartości użycia pamięci są niższe niż oczekiwano w usłudze Microsoft Azure Container Instances podczas sprawdzania wartości w witrynie Azure Portal.
Symptomy
Podczas sprawdzania metryki użycia pamięci w grupie kontenerów z wieloma kontenerami w witrynie Azure Portal metryka pokazuje wartości, które są niższe niż te, które są widoczne podczas uruchamiania bezpłatnego polecenia -h podczas nawiązywania połączenia z głównym kontenerem.
Przyczyna
Metryka użycia pamięci w witrynie Azure Portal wyświetla średnią wartość dla wszystkich kontenerów, które znajdują się w grupie kontenerów. Nie pokazuje użycia pamięci tylko dla jednego określonego kontenera. Ta metryka jest obliczana przy użyciu domyślnego interwału czasu jednej minuty. Średnie użycie wielu kontenerów może spowodować, że użycie pamięci wyświetlane w witrynie Azure Portal różni się nieco od użycia wyświetlanego w danych wyjściowych free
polecenia.
Wartości dla typów agregacji (takich jak Średnia, Minimum i Maksimum) są dostępne tylko jako średnia dla wszystkich kontenerów w grupie kontenerów. Te statystyki nie są dostępne dla pojedynczego kontenera w grupie kontenerów, która ma wiele kontenerów. Aby uzyskać więcej informacji, zobacz Obsługiwane metryki na typ zasobu w usłudze Azure Monitor.
Rozwiązanie
Możesz dodać filtr wymiarów, aby wyświetlić metryki dla poszczególnych kontenerów, jeśli grupa kontenerów zawiera wiele kontenerów. Aby uzyskać więcej informacji, zobacz Pobieranie metryk w witrynie Azure Portal podczas monitorowania zasobów kontenera w usłudze Azure Container Instances.
Odwołanie
Obsługiwane metryki dla obiektów Microsoft.ContainerInstance/containerGroups
Samouczek: wdrażanie grupy z wieloma kontenerami przy użyciu szablonu usługi Azure Resource Manager
Zastrzeżenie dotyczące innych firm
Produkty innych firm omówione w tym artykule są wytwarzane przez producentów niezależnych od firmy Microsoft. Firma Microsoft nie udziela żadnych gwarancji, dorozumianych ani żadnego innego rodzaju, w odniesieniu do wydajności lub niezawodności tych produktów.
Skontaktuj się z nami, aby uzyskać pomoc
Jeśli masz pytania lub potrzebujesz pomocy, utwórz wniosek o pomoc techniczną lub zadaj pytanie w społeczności wsparcia dla platformy Azure. Możesz również przesłać opinię o produkcie do społeczności opinii na temat platformy Azure.