Uruchamianie ściągania obrazu trwa długo
W tym artykule opisano, co można zrobić, jeśli ściąganie obrazu trwa długo w usłudze Microsoft Azure Container Instances.
Wymagania wstępne
Symptomy
Grupy kontenerów są zablokowane w stanie "Utworzono" przez znaczną ilość czasu.
Rozmiar obrazu używany dla grupy kontenerów jest duży.
Przyczyna
W usłudze Container Instances obrazy nie są buforowane na zawsze. Jeśli obraz nie jest buforowany, obraz jest ściągany z rejestru. Ściąganie rejestru może zająć dużo czasu, jeśli obraz jest duży. Jest to oczekiwane zachowanie w przypadku dużych, niebuforowanych obrazów.
Jeśli potrzebujesz krótszych czasów ściągnięcia, możesz sprawdzić, czy jeden z wymienionych obrazów buforowanych będzie działał pomyślnie dla danego przypadku użycia.
Rozwiązanie
Uruchom następujące polecenie az container show , aby wyświetlić oś czasu zdarzeń kontenera:
az container show --resource-group <resource-group-name> --name <container-group-name>
W tym przykładzie Pulling
zdarzenie obrazu rozpoczyna się o godzinie 16:30:51, a pomyślne Pulled
zdarzenie jest rejestrowane w tym samym dniu o godzinie 16:48:43. W związku z tym ściąganie obrazu trwa prawie 18 minut. Te informacje umożliwiają określenie, czy czas ściągnięcia obrazu jest oczekiwany, czy nietypowy.
{
"containers": [
{
"command": null,
"environmentVariables": [],
"image": "pbdockerregistry-on.azurecr.io/software:166884UK",
"instanceView": {
"currentState": {
"detailStatus": "",
"exitCode": null,
"finishTime": null,
"startTime": "2019-01-22T16:49:11+00:00",
"state": "Running"
},
"events": [
{
"count": 1,
"firstTimestamp": "2019-01-22T16:30:51+00:00",
"lastTimestamp": "2019-01-22T16:30:51+00:00",
"message": "pulling image \"pbdockerregistry-on.azurecr.io/software:166884UK\"",
"name": "Pulling",
"type": "Normal"
},
{
"count": 1,
"firstTimestamp": "2019-01-22T16:48:43+00:00",
"lastTimestamp": "2019-01-22T16:48:43+00:00",
"message": "Successfully pulled image \"pbdockerregistry-on.azurecr.io/software:166884UK\"",
"name": "Pulled",
"type": "Normal"
},
{
"count": 1,
"firstTimestamp": "2019-01-22T16:48:43+00:00",
"lastTimestamp": "2019-01-22T16:48:43+00:00",
"message": "Created container with docker id 2dfc27ee4e6",
"name": "Created",
"type": "Normal"
},
{
"count": 1,
"firstTimestamp": "2019-01-22T16:49:11+00:00",
"lastTimestamp": "2019-01-22T16:49:11+00:00",
"message": "Started container with docker id 2edfc27ee4e6",
"name": "Started",
"type": "Normal"
}
],
"previousState": null,
"restartCount": 0
},
"livenessProbe": null,
"name": "<container-name>",
"ports": [
{
"port": 443,
"protocol": "TCP"
}
],
"readinessProbe": null,
"resources": {
"limits": null,
"requests": {
"cpu": 4.0,
"memoryInGb": 4.0
}
},
"volumeMounts": null
}
],
"diagnostics": null,
"id": "/subscriptions/<subscription-id>/resourceGroups/<resource-group-name>/providers/Microsoft.ContainerInstance/containerGroups/<container-name>",
"identity": null,
"imageRegistryCredentials": [
{
"password": null,
"server": "<user-name>.azurecr.io",
"username": "<user-name>"
}
],
"instanceView": {
"events": [],
"state": "Running"
},
"ipAddress": {
"dnsNameLabel": "<container-name>",
"fqdn": "<container-name>.westeurope.azurecontainer.io",
"ip": "40.119.152.151",
"ports": [
{
"port": 443,
"protocol": "TCP"
}
],
"type": "Public"
},
"location": "westeurope",
"name": "<container-name>",
"networkProfile": null,
"osType": "Windows",
"provisioningState": "Succeeded",
"resourceGroup": "<resource-group-name>",
"restartPolicy": "Always",
"tags": {},
"type": "Microsoft.ContainerInstance/containerGroups",
"volumes": null
}
Więcej informacji
Skontaktuj się z nami, aby uzyskać pomoc
Jeśli masz pytania lub potrzebujesz pomocy, utwórz wniosek o pomoc techniczną lub zadaj pytanie w społeczności wsparcia dla platformy Azure. Możesz również przesłać opinię o produkcie do społeczności opinii na temat platformy Azure.