Udostępnij za pośrednictwem


Błąd AADSTS650056 — nieprawidłowo skonfigurowana aplikacja

W tym artykule opisano problem, w którym podczas próby zalogowania się do aplikacji skonfigurowanej przy użyciu logowania jednokrotnego opartego na protokole SAML (SSO) jest wyświetlany następujący komunikat o błędzie, który został zintegrowany z identyfikatorem Microsoft Entra ID:

Błąd AADSTS650056 — nieprawidłowo skonfigurowana aplikacja. Może to być spowodowane jedną z następujących przyczyn: klient nie wymienił żadnych uprawnień dla elementu "{name}" w żądanych uprawnieniach w rejestracji aplikacji klienta. Lub administrator nie wyraził zgody w dzierżawie. Lub sprawdź identyfikator aplikacji w żądaniu, aby upewnić się, że jest on zgodny ze skonfigurowanym identyfikatorem aplikacji klienckiej. Możesz też sprawdzić certyfikat w żądaniu, aby upewnić się, że jest prawidłowy. Skontaktuj się z administratorem, aby naprawić konfigurację lub uzyskać zgodę w imieniu dzierżawy. Identyfikator aplikacji klienckiej: {id}. Skontaktuj się z administratorem, aby naprawić konfigurację lub uzyskać zgodę w imieniu dzierżawy.

Symptomy

AADSTS650056 Podczas próby zalogowania się do aplikacji, która została skonfigurowana do używania identyfikatora Entra firmy Microsoft do zarządzania tożsamościami przy użyciu logowania jednokrotnego opartego na protokole SAML.

Przyczyna

Atrybut Issuer wysyłany z aplikacji do identyfikatora Entra firmy Microsoft w żądaniu SAML nie jest zgodny z wartością Identyfikator skonfigurowaną dla aplikacji w identyfikatorze Entra firmy Microsoft.

Rozwiązanie

Upewnij się, że Issuer atrybut w żądaniu SAML jest zgodny z wartością Identyfikator skonfigurowaną w identyfikatorze Entra firmy Microsoft.

Sprawdź, czy wartość w polu tekstowym identyfikatora jest zgodna z wartością identyfikatora wyświetlaną w komunikacie o błędzie.

Aby uzyskać więcej informacji na temat atrybutu Wystawca, zobacz Protokół SAML logowania jednokrotnego.

Więcej informacji

Aby uzyskać pełną listę kodów błędów uwierzytelniania i autoryzacji usługi Active Directory, zobacz Kody błędów uwierzytelniania i autoryzacji firmy Microsoft.

Skontaktuj się z nami, aby uzyskać pomoc

Jeśli masz pytania lub potrzebujesz pomocy, utwórz wniosek o pomoc techniczną lub zadaj pytanie w społeczności wsparcia dla platformy Azure. Możesz również przesłać opinię o produkcie do społeczności opinii na temat platformy Azure.