Udostępnij za pośrednictwem


Błąd AADSTS50011 z uwierzytelnianiem SAML — adres URL odpowiedzi określony w żądaniu jest niezgodny

Ten artykuł zawiera rozwiązanie błędu AADSTS50011 występującego podczas uwierzytelniania federacyjnego przy użyciu identyfikatora Entra firmy Microsoft.

Symptomy

Podczas próby zalogowania się do aplikacji skonfigurowanej do używania identyfikatora Entra firmy Microsoft do zarządzania tożsamościami przy użyciu logowania jednokrotnego opartego na protokole SAML występuje błąd AADSTS50011 .

Błąd AADSTS50011 — adres URL odpowiedzi jest niezgodny z adresami URL odpowiedzi skonfigurowanymi dla identyfikatora GUID> aplikacji<. Upewnij się, że adres URL odpowiedzi wysłany w żądaniu jest zgodny z adresem dodanym do aplikacji w witrynie Azure Portal. Przejdź do witryny , https://aka.ms/urlMismatchError aby dowiedzieć się więcej o tym, jak rozwiązać ten problem. Podczas próby zalogowania się do aplikacji skonfigurowanej przy użyciu logowania jednokrotnego (SSO) opartego na protokole SAML, która została zintegrowana z identyfikatorem Microsoft Entra ID.

Przyczyna

AssertionConsumerServiceURL Wartość w żądaniu SAML nie jest zgodna z wartością lub wzorcem adresu URL odpowiedzi skonfigurowanym w identyfikatorze Entra firmy Microsoft. Wartość AssertionConsumerServiceURL w żądaniu SAML to adres URL wyświetlany w komunikacie o błędzie.

Rozwiązanie

Aby rozwiązać ten problem, wykonaj poniższe kroki:

  1. Upewnij się, że AssertionConsumerServiceURL wartość w żądaniu SAML jest zgodna z wartością Adresu URL odpowiedzi skonfigurowaną w identyfikatorze Entra firmy Microsoft.
  2. Sprawdź lub zaktualizuj wartość w polu tekstowym Adres URL odpowiedzi, aby była zgodna z wartością AssertionConsumerServiceURL w żądaniu SAML.

Na przykład zapoznaj się z następującym artykułem, aby uzyskać szczegółowe instrukcje dotyczące konfigurowania wartości w usłudze Microsoft Entra ID:

Uwaga 16.

Adres URL odpowiedzi jest również nazywany identyfikatorem URI przekierowania. Te wartości zależą od używanej aplikacji. Należy uzyskać wartości od dostawcy aplikacji.

Po zaktualizowaniu wartości Adresu URL odpowiedzi w identyfikatorze Entra firmy Microsoft i dopasowaniu jej do wartości wysłanej przez aplikację w żądaniu SAML powinno być możliwe zalogowanie się do aplikacji.

Więcej informacji

Aby uzyskać pełną listę kodów błędów uwierzytelniania i autoryzacji usługi Active Directory, zobacz Kody błędów uwierzytelniania i autoryzacji firmy Microsoft.

Skontaktuj się z nami, aby uzyskać pomoc

Jeśli masz pytania lub potrzebujesz pomocy, utwórz wniosek o pomoc techniczną lub zadaj pytanie w społeczności wsparcia dla platformy Azure. Możesz również przesłać opinię o produkcie do społeczności opinii na temat platformy Azure.