Udostępnij za pośrednictwem


Błąd AADSTS50003 — nie skonfigurowano klucza podpisywania

W tym artykule opisano problem, w którym jest wyświetlany komunikat o błędzie "Błąd AADSTS50003 — brak skonfigurowanego klucza podpisywania". Podczas próby zalogowania się do skonfigurowanej aplikacji logowania jednokrotnego opartego na protokole SAML (SSO) zintegrowanej z identyfikatorem Microsoft Entra ID.

Symptomy

AADSTS50003 Podczas próby zalogowania się do aplikacji, która została skonfigurowana do używania identyfikatora Entra firmy Microsoft do zarządzania tożsamościami przy użyciu logowania jednokrotnego opartego na protokole SAML.

Przyczyna

Obiekt aplikacji jest uszkodzony, a identyfikator Entra firmy Microsoft nie rozpoznaje certyfikatu skonfigurowanego dla aplikacji.

Rozwiązanie

Aby usunąć i utworzyć nowy certyfikat, wykonaj poniższe kroki:

  1. Na ekranie konfiguracji logowania jednokrotnego opartego na protokole SAML wybierz pozycję Utwórz nowy certyfikat w sekcji Certyfikat podpisywania SAML.
  2. Wybierz pozycję Data wygaśnięcia, a następnie kliknij przycisk Zapisz.
  3. Zaznacz pozycję Oznacz nowy certyfikat jako aktywny, aby przesłonić aktywny certyfikat. Następnie kliknij przycisk Zapisz w górnej części okienka i zaakceptuj, aby aktywować certyfikat przerzucania.
  4. W sekcji Certyfikat podpisywania SAML kliknij przycisk usuń, aby usunąć nieużywany certyfikat.

Więcej informacji

Aby uzyskać pełną listę kodów błędów uwierzytelniania i autoryzacji usługi Active Directory, zobacz Kody błędów uwierzytelniania i autoryzacji firmy Microsoft

Skontaktuj się z nami, aby uzyskać pomoc

Jeśli masz pytania lub potrzebujesz pomocy, utwórz wniosek o pomoc techniczną lub zadaj pytanie w społeczności wsparcia dla platformy Azure. Możesz również przesłać opinię o produkcie do społeczności opinii na temat platformy Azure.