Wyszukiwanie hybrydowe nie może przeszukiwać ani zwracać wyników
Symptomy
Podczas korzystania z wyszukiwania hybrydowego w programie SharePoint na platformie Microsoft 365 występuje co najmniej jeden z następujących problemów:
- Przeszukiwanie kończy się niepowodzeniem.
- Nie jest zwracany żaden wynik.
- Zostanie wyświetlony komunikat o błędzie, taki jak "Wymuszone zamknięcie istniejącego połączenia".
Przyczyna
Rozpoczęliśmy wycofywanie protokołów TLS 1.1 i 1.0 na platformie Microsoft 365. Od 30 czerwca 2021 r. usługa wyszukiwania nie będzie już akceptować połączeń korzystających z protokołu TLS 1.1 lub 1.0. Jeśli używasz aplikacji usługa wyszukiwania w chmurze (SSA) w starszych wersjach systemu Windows, musisz ręcznie włączyć protokół TLS 1.2, aby zawartość lokalna była indeksowana w programie SharePoint na platformie Microsoft 365.
Rozwiązanie
Aby rozwiązać ten problem, włącz protokół TLS 1.2, wykonując następujące instrukcje:
- Włączanie obsługi protokołu TLS i obsługi protokołu SSL w programie SharePoint 2013
- Włączanie obsługi protokołu TLS 1.1 i TLS 1.2 w programie SharePoint Server 2016
- Włącz obsługę protokołów TLS 1.1 i TLS 1.2 w SharePoint Server 2019
Uwaga
Jeśli nadal występują te problemy w systemie Windows Server 2012 lub Windows Server 2008 R2 z dodatkiem SP1, wypróbuj następujące rozwiązania:
- Narzędzie Easy Fix Tool może automatycznie dodawać klucze rejestru protokołu TLS 1.2 i TLS 1.1 Secure Protocol. Aby uzyskać więcej informacji, zobacz Aktualizacja, aby włączyć protokół TLS 1.1 i TLS 1.2 jako domyślne protokoły zabezpieczeń w WinHTTP w systemie Windows.
- W przypadku Windows Server 2012 jeśli po uruchomieniu narzędzia Easy Fix Tool nadal występują sporadyczne błędy łączności, rozważ wyłączenie zestawów szyfrowania DHE. Aby uzyskać więcej informacji, zobacz Aplikacje napotkają wymuszone błędy połączenia TLS podczas nawiązywania połączenia z serwerami SQL Server w systemie Windows.
Sprawdź również obsługiwane zestawy szyfrowania i kolejność sortowania zestawu szyfrowania. W przypadku protokołu TLS 1.2 przez usługę Azure Front Door obsługiwane są następujące zestawy szyfrowania:
- TLS_ECDHE_RSA_WITH_AES_256_GCM_SHA384
- TLS_ECDHE_RSA_WITH_AES_128_GCM_SHA256
- TLS_DHE_RSA_WITH_AES_256_GCM_SHA384
- TLS_DHE_RSA_WITH_AES_128_GCM_SHA256
Aby dodać zestawy szyfrowania, wdróż ustawienie zasady grupy lub użyj lokalnego zasady grupy Redaktor, zgodnie z opisem w temacie Konfigurowanie kolejności zestawu szyfrowania TLS przy użyciu zasady grupy.
Ważna
Zmień kolejność zestawów szyfrowania, aby upewnić się, że te cztery zestawy znajdują się na szczycie listy (najwyższy priorytet).
Aby uzyskać więcej informacji, zobacz Jakie są bieżące mechanizmy szyfrowania obsługiwane przez usługę Azure Front Door?.
Informacje
- Przygotowanie do protokołu TLS 1.2 na platformach Microsoft 365 i Microsoft 365 GCC
- Błędy uwierzytelniania występują, gdy klient nie obsługuje protokołu TLS 1.2
Nadal potrzebujesz pomocy? Przejdź do witryny SharePoint Community.