Udostępnij za pośrednictwem


Użytkownicy korzystający z zasad programu Outlook dla systemów iOS i Android oraz dostępu do urządzeń (ABQ) są nieoczekiwanie poddani kwarantannie

Oryginalny numer KB: 3193518

Symptomy

Exchange Online użytkowników korzystających z programu Outlook dla systemów iOS i Android oraz korzystających z reguł dostępu do urządzeń (ABQ) stwierdzi, że zostały one nieoczekiwanie poddane kwarantannie. Ten problem występuje w następującym scenariuszu:

  • Właściwość dzierżawy skonfigurowana DefaultAccessLevel za pośrednictwem Set-ActiveSyncOrganizationSettings jest ustawiona na wartość Kwarantanna lub Blokuj.
  • Administrator dzierżawy zezwolił wcześniej na program Outlook dla systemów iOS i Android, ostemplując identyfikator DeviceID we ActiveSyncAllowedDeviceIDs właściwości skrzynki pocztowej.
  • Urządzenia nie są zarządzane przez Microsoft Intune.

Przyczyna

Zmiana protokołu zaplecza w sposobie uzyskiwania dostępu do danych skrzynki pocztowej platformy Microsoft 365 za pośrednictwem aplikacji Outlook dla systemów iOS i Android zmienia identyfikator Urządzenia używany przez aplikację do nawiązywania połączenia z Exchange Online. Oczekiwane zachowanie polega na tym, że nowy identyfikator DeviceID zostanie automatycznie dodany do ActiveSyncAllowedDeviceID elementu dla użytkownika. Jednak w niektórych scenariuszach urządzenie może zostać poddane kwarantannie. W takich przypadkach wykonaj kroki opisane w sekcji Rozwiązywanie problemów. Ten problem nie powinien występować wielokrotnie.

Rozwiązanie

Skontaktuj się z pomocą techniczną i poproś przedstawiciela działu obsługi klienta o pomoc w odblokowaniu urządzenia.

Możesz też użyć jednej z następujących metod, aby odblokować urządzenie:

  • Odblokuj poszczególne urządzenia za pomocą centrum administracyjnego programu Exchange. Aby to zrobić, wykonaj następujące kroki.

    1. Zaloguj się do centrum administracyjnego programu Exchange. Aby uzyskać więcej informacji, zobacz Centrum administracyjne programu Exchange w usłudze Exchange Online.
    2. Wybierz pozycję urządzenia przenośne, a następnie w obszarze Urządzenia poddane kwarantannie wybierz przycisk Zezwalaj dla każdego urządzenia aplikacji Outlook dla systemów iOS i Android, które musi zostać odblokowane.
  • Użyj zdalnego programu PowerShell, aby odblokować wszystkie urządzenia. Aby to zrobić, wykonaj następujące kroki.

    1. Połącz się z usługą Exchange Online przy użyciu zdalnej obsługi programu PowerShell. Aby uzyskać więcej informacji, zobacz Nawiązywanie połączenia z usługą Exchange Online przy użyciu programu PowerShell.

    2. Skopiuj i wklej następujący kod do zdalnej sesji programu PowerShell:

      function FixUnblock { $Mbxs = Get-CASMailbox -ResultSize 10000 | ?{$_.ActiveSyncAllowedDeviceIDs -ne $null } foreach($Mbx in $Mbxs) { write-host $Mbx.Id $IdList = Get-MobileDevice -Mailbox $Mbx.Id | where {$_.DeviceModel -eq "Outlook for iOS and Android" -and $_.ClientType -eq "REST" -and $_.DeviceAccessState -ne "Allowed" -and $_.FirstSyncTime -ge "9/13/2016"} $CasDevice = Get-CasMailbox $Mbx.Id foreach( $Id in $IdList) { $CasDevice.ActiveSyncAllowedDeviceIDs += $Id.DeviceId } Set-CasMailbox $Mbx.Id -ActiveSyncAllowedDeviceIDs $CasDevice.ActiveSyncAllowedDeviceIDs } }
      
    3. W zdalnej sesji programu PowerShell uruchom funkcję. Aby to zrobić, wpisz FixUnblock, a następnie naciśnij klawisz Enter.

Więcej informacji

Użytkownicy z nowoczesnymi kontami z obsługą uwierzytelniania muszą wykonać kroki opisane w temacie Konfiguracja konta z nowoczesnym uwierzytelnianiem w Exchange Online, aby skonfigurować swoje konta programu Outlook dla systemów iOS i Android.

Nadal potrzebujesz pomocy? Przejdź do witryny Microsoft Community.