Błąd podczas otwierania pliku w usłudze Teams: Nie masz dostępu do tego pliku
Symptomy
W usłudze Microsoft Teams pliki udostępniane są innym użytkownikom w oknie czatu. Następnie pliki są automatycznie zapisywane w witrynie OneDrive. Gdy inny użytkownik próbuje otworzyć plik w usłudze Teams, wyświetlany jest następujący komunikat o błędzie:
Nie masz dostępu do tego pliku.
Przyczyna
Problem ten występuje, ponieważ aktywowany jest tryb blokowania uprawnień użytkownika z ograniczonym dostępem w witrynie OneDrive. Jest to funkcja zbioru witryn, która pomaga uniemożliwić anonimowym użytkownikom dostęp do stron aplikacji, które są najczęściej pomocne w klasycznych witrynach programu SharePoint opartych na publikowaniu. Zaleca się, aby nie włączać tej funkcji w witrynach usługi OneDrive.
Rozwiązanie
Aby rozwiązać ten problem, zdezaktywuj tę funkcję w usłudze OneDrive.
- Zaloguj się do witryny usługi OneDrive.
- Wybierz ikonę Ustawienia w prawym górnym rogu ekranu.
- Wybierz pozycję Ustawienia usługi OneDrive>Więcej ustawień.
- W obszarze Funkcje i magazyn wybierz pozycję Funkcje zbioru witryn.
- Znajdź tryb blokady uprawnień użytkownika z ograniczonym dostępem, a następnie wybierz pozycję Dezaktywuj.
Aby uzyskać więcej informacji na temat trybu blokowania uprawnień użytkownika z ograniczonym dostępem, zobacz artykuł Włączanie lub wyłączanie funkcji zbioru witryn.
Uruchamianie narzędzia do samodzielnej diagnostyki
Użytkownicy administracyjni Microsoft 365 mają dostęp do diagnostyki, która może być uruchamiana w ramach dzierżawy w celu zweryfikowania możliwych problemów z uzyskiwaniem dostępu do plików udostępnionych na czacie w aplikacji Teams.
Uwaga
Ta funkcja nie jest dostępna w usługach Microsoft 365 dla instytucji, Microsoft 365 obsługiwany przez 21Vianet lub Microsoft 365 Germany.
Wybierz z poniższych opcję Uruchom testy. Spowoduje ona wypełnienie diagnostyki w Centrum administracyjnym Microsoft 365.
Diagnostyka wykonuje dużą liczbę weryfikacji.
Potrzebujesz więcej pomocy?
Pomoc można uzyskać w społeczności online Microsoft Community, wyszukując dodatkowe informacje w witrynie pomocy technicznej firmy Microsoft lub w witrynie pomocy i instrukcji dotyczących pakietu Office albo korzystając z informacji o opcjach asystowanej pomocy technicznej.