Udostępnij za pośrednictwem


Rozwiązywanie problemów z błędami przy użyciu usługi Azure Blueprints

Ważne

11 lipca 2026 r. usługa Blueprints (wersja zapoznawcza) zostanie wycofana. Przeprowadź migrację istniejących definicji strategii i przypisań do specyfikacji szablonu i stosów wdrażania. Artefakty strategii mają być konwertowane na szablony JSON usługi ARM lub pliki Bicep używane do definiowania stosów wdrażania. Aby dowiedzieć się, jak utworzyć artefakt jako zasób usługi ARM, zobacz:

Podczas tworzenia, przypisywania lub usuwania strategii mogą występować błędy. W tym artykule opisano różne błędy, które mogą wystąpić i jak je rozwiązać.

Znajdowanie szczegółów błędu

Wiele błędów jest wynikiem przypisywania strategii do zakresu. Gdy przypisanie nie powiedzie się, strategia będzie zawierać szczegółowe informacje o nieudanym wdrożeniu. Te informacje wskazują problem, aby można było go rozwiązać i pomyślnie przeprowadzić następne wdrożenie.

  1. W okienku po lewej stronie wybierz pozycję Wszystkie usługi. Wyszukaj i wybierz pozycję Strategie.

  2. Wybierz pozycję Przypisane strategie ze strony po lewej i użyj pola wyszukiwania, aby przefiltrować przypisania strategii w celu znalezienia nieudanego przypisania. Możesz również posortować tabelę przypisań według kolumny Stan aprowizacji, aby wyświetlić wszystkie nieudane przypisania pogrupowane razem.

  3. Wybierz strategię ze stanem Niepowodzenie lub kliknij prawym przyciskiem myszy i wybierz pozycję Wyświetl szczegóły przypisania.

  4. U góry strony przypisywania strategii wyświetlany jest czerwony baner z ostrzeżeniem, że przypisanie nie powiodło się. Wybierz dowolne miejsce na banerze, aby uzyskać więcej szczegółów.

Często występuje błąd spowodowany przez artefakt, a nie przez całą strategię. Jeśli artefakt tworzy magazyn kluczy, a usługa Azure Policy uniemożliwia utworzenie takiego magazynu, całe przypisanie kończy się niepowodzeniem.

Błędy ogólne

Scenariusz: naruszenie zasad

Problem

Wdrożenie szablonu nie powiodło się z powodu naruszenia zasad.

Przyczyna

Zasady mogą powodować konflikt z wdrożeniem z następujących powodów:

  • Tworzony zasób jest ograniczony przez zasady (często jednostki SKU lub ograniczenia lokalizacji)
  • Wdrożenie ustawia pola skonfigurowane przez zasady (wspólne z tagami)

Rozwiązanie

Zmień strategię, aby nie powodować konfliktu z zasadami w szczegółach błędu. Jeśli ta zmiana nie jest możliwa, alternatywną opcją jest zmiana zakresu przypisania zasad, więc strategia nie jest już w konflikcie z zasadami.

Scenariusz: Parametr strategii jest funkcją

Problem

Parametry strategii, które są funkcjami, są przetwarzane przed przekazaniem ich do artefaktów.

Przyczyna

Przekazywanie parametru strategii, który używa funkcji, takiej jak [resourceGroup().tags.myTag], do artefaktu powoduje przetworzenie wyniku funkcji ustawianej na artefakt zamiast funkcji dynamicznej.

Rozwiązanie

Aby przekazać funkcję jako parametr, należy uruchomić cały ciąg, [ tak aby parametr strategii wyglądał następująco: [[resourceGroup().tags.myTag]. Znak ucieczki powoduje, że strategie traktują wartość jako ciąg podczas przetwarzania strategii. Następnie usługa Blueprints umieszcza funkcję na artefaktie, umożliwiając jej dynamiczne działanie zgodnie z oczekiwaniami. Aby uzyskać więcej informacji, zobacz Składnia i wyrażenia w szablonach usługi Azure Resource Manager.

Błędy usuwania

Scenariusz: przekroczenie limitu czasu usuwania przydziału

Problem

Usunięcie przypisania strategii nie zostało ukończone.

Przyczyna

Przypisanie strategii może zostać zablokowane w stanie nie terminalu po usunięciu. Ten stan jest spowodowany tym, że zasoby utworzone przez przypisanie strategii nadal oczekują na usunięcie lub nie zwracają kodu stanu do usługi Azure Blueprints.

Rozwiązanie

Przypisania strategii w stanie nie terminalu są automatycznie oznaczone jako Niepowodzenie po upływie sześciogodzinnego limitu czasu. Po dostosowaniu limitu czasu przypisania strategii można ponowić próbę usunięcia.

Następne kroki

Jeśli problem nie został wyświetlony lub nie możesz go rozwiązać, odwiedź jeden z następujących kanałów, aby uzyskać więcej pomocy technicznej:

  • Uzyskaj odpowiedzi od ekspertów platformy Azure za pośrednictwem forów platformy Azure.
  • Połącz się z @AzureSupport — oficjalne konto platformy Microsoft Azure w celu poprawy jakości obsługi klienta przez połączenie społeczności platformy Azure z odpowiednimi zasobami: odpowiedziami, pomocą techniczną i ekspertami.
  • Jeśli potrzebujesz dodatkowej pomocy, możesz zgłosić zdarzenie pomoc techniczna platformy Azure. Przejdź do witryny pomoc techniczna platformy Azure i wybierz pozycję Uzyskaj pomoc techniczną.