Rozwiązywanie problemów z wdrażaniem funkcji
Ważne
Śledzenie zmian i spis korzystanie z agenta usługi Log Analytics zostało wycofane 31 sierpnia 2024 r. i będzie działać w sprawie ograniczonej pomocy technicznej do 01 lutego 2025 r. Zalecamy użycie agenta monitorowania platformy Azure jako nowego agenta pomocniczego. Postępuj zgodnie z wytycznymi dotyczącymi migracji ze śledzenia zmian i spisu przy użyciu usługi analizy dzienników do śledzenia zmian i spisu przy użyciu wersji agenta monitorowania platformy Azure.
Podczas wdrażania funkcji rozwiązania Azure Automation Update Management lub funkcji Śledzenie zmian i spis na maszynach wirtualnych mogą pojawić się komunikaty o błędach. W tym artykule opisano błędy, które mogą wystąpić, i sposoby ich usunięcia.
Znane problemy
Scenariusz: zmiana nazwy zarejestrowanego węzła wymaga wyrejestrowania lub ponownego zarejestrowania
Problem
Węzeł jest zarejestrowany w usłudze Azure Automation, a następnie zmieniana jest nazwa komputera systemu operacyjnego. Raporty z węzła będą nadal wyświetlane z oryginalną nazwą.
Przyczyna
Zmiana nazwy zarejestrowanych węzłów nie powoduje aktualizacji nazwy węzła w usłudze Azure Automation.
Rozwiązanie
Wyrejestruj węzeł z usługi Azure Automation State Configuration, a następnie zarejestruj go ponownie. Raporty opublikowane w usłudze przed tym czasem nie będą już dostępne.
Scenariusz: ponowne podpisywanie certyfikatów za pośrednictwem serwera proxy HTTPS nie jest obsługiwane
Problem
Po nawiązaniu połączenia za pośrednictwem serwera proxy, który przerywa ruch HTTPS, a następnie ponownie szyfruje ruch przy użyciu nowego certyfikatu, usługa nie zezwala na połączenie.
Przyczyna
Usługa Azure Automation nie obsługuje ponownego podpisywania certyfikatów używanych do szyfrowania ruchu.
Rozwiązanie
Obecnie nie ma obejścia tego problemu.
Błędy ogólne
Scenariusz: wdrażanie funkcji kończy się niepowodzeniem z komunikatem "Nie można włączyć rozwiązania"
Problem
Podczas próby włączenia funkcji na maszynie wirtualnej jest wyświetlany jeden z następujących komunikatów:
The solution cannot be enabled due to missing permissions for the virtual machine or deployments
The solution cannot be enabled on this VM because the permission to read the workspace is missing
Przyczyna
Ten błąd jest spowodowany nieprawidłowymi lub brakującymi uprawnieniami na maszynie wirtualnej lub w obszarze roboczym albo dla użytkownika.
Rozwiązanie
Upewnij się, że masz odpowiednie uprawnienia do wdrażania funkcji, a następnie spróbuj ponownie wdrożyć tę funkcję. Jeśli zostanie wyświetlony komunikat The solution cannot be enabled on this VM because the permission to read the workspace is missing
o błędzie , zobacz następujące informacje dotyczące rozwiązywania problemów.
Scenariusz: Wdrażanie funkcji kończy się niepowodzeniem z komunikatem „Nie można skonfigurować konta usługi Automation na potrzeby rejestrowania diagnostycznego”
Problem
Podczas próby włączenia funkcji na maszynie wirtualnej zostanie wyświetlony następujący komunikat:
Failed to configure automation account for diagnostic logging
Przyczyna
Ten błąd może być spowodowany tym, że warstwa cenowa nie jest zgodna z modelem rozliczeń subskrypcji. Aby uzyskać więcej informacji, zobacz Monitorowanie użycia i szacowanych kosztów w usłudze Azure Monitor.
Rozwiązanie
Ręcznie utwórz obszar roboczy usługi Log Analytics i powtórz proces wdrażania funkcji, aby wybrać utworzony obszar roboczy.
Scenariusz: ComputerGroupQueryFormatError
Problem
Ten kod błędu oznacza, że zapisane zapytanie dotyczące wyszukiwania grupy komputerów używane do określania elementu docelowego funkcji nie jest poprawnie sformatowane.
Przyczyna
Zapytanie mogło zostać zmienione przez użytkownika lub przez system.
Rozwiązanie
Możesz usunąć zapytanie dla funkcji, a następnie ponownie włączyć tę funkcję, co spowoduje ponowne utworzenie zapytania. Zapytanie można znaleźć w obszarze roboczym w sekcji Zapisane wyszukiwania. Nazwa zapytania to MicrosoftDefaultComputerGroup, a kategoria zapytania to nazwa skojarzonej funkcji. Jeśli włączono wiele funkcji, zapytanie MicrosoftDefaultComputerGroup jest wyświetlane wiele razy w sekcji Zapisane wyszukiwania.
Scenariusz: PolicyViolation
Problem
Ten kod błędu wskazuje, że wdrożenie nie powiodło się z powodu naruszenia co najmniej jednego przypisania usługi Azure Policy.
Przyczyna
Przypisanie usługi Azure Policy blokuje ukończenie operacji.
Rozwiązanie
Aby pomyślnie wdrożyć tę funkcję, należy rozważyć zmianę wskazanej definicji zasad. Ponieważ istnieje wiele różnych typów definicji zasad, które można określić, wymagane zmiany zależą od definicji zasady, która została naruszona. Jeśli na przykład definicja zasady jest przypisana do grupy zasobów, która odmawia uprawnień do zmiany zawartości niektórych zawartych zasobów, możesz wybrać jedną z następujących poprawek:
- Całkowicie usuń przypisanie zasad.
- Spróbuj włączyć funkcję dla innej grupy zasobów.
- Utwórz ponownie przypisanie zasad do określonego zasobu, na przykład konta usługi Automation.
- Popraw zestaw zasobów skonfigurowanych do odmowy definicji zasad.
Sprawdź powiadomienia w prawym górnym rogu witryny Azure Portal lub przejdź do grupy zasobów zawierającej konto usługi Automation i wybierz pozycję Wdrożenia w obszarze Ustawienia , aby wyświetlić nieudane wdrożenie. Aby dowiedzieć się więcej na temat usługi Azure Policy, zobacz Omówienie usługi Azure Policy.
Scenariusz: Błędy próbujące odłączyć obszar roboczy
Problem
Podczas próby odłączenia obszaru roboczego zostanie wyświetlony następujący komunikat o błędzie:
The link cannot be updated or deleted because it is linked to Update Management and/or ChangeTracking Solutions.
Przyczyna
Ten błąd występuje, gdy nadal masz aktywne funkcje w obszarze roboczym usługi Log Analytics, które zależą od konta usługi Automation i połączonego obszaru roboczego usługi Log Analytics.
Rozwiązanie
Usuń zasoby dla następujących funkcji z obszaru roboczego, jeśli ich używasz:
- Zarządzanie aktualizacjami
- Śledzenie zmian i spis
- Uruchamianie lub zatrzymywanie maszyn wirtualnych po godzinach pracy
Po usunięciu zasobów funkcji możesz odłączyć obszar roboczy. Ważne jest, aby wyczyścić wszystkie istniejące artefakty z tych funkcji z obszaru roboczego i konta usługi Automation:
- W przypadku rozwiązania Update Management usuń wdrożenia aktualizacji (harmonogramy) z konta usługi Automation.
- W przypadku uruchamiania/zatrzymywania maszyn wirtualnych poza godzinami pracy usuń wszelkie blokady składników funkcji na koncie usługi Automation w obszarze Blokady ustawień>. Aby uzyskać więcej informacji, zobacz Usuwanie funkcji.
Usługa Log Analytics dla błędów rozszerzeń systemu Windows
Uwaga
W ramach trwającego przejścia z pakietu Microsoft Operations Management Suite do usługi Azure Monitor agent pakietu Operations Management Suite dla systemu Windows lub Linux będzie określany jako agent usługi Log Analytics dla systemu Windows i agent usługi Log Analytics dla systemu Linux.
Instalacja agenta usługi Log Analytics dla rozszerzenia systemu Windows może zakończyć się niepowodzeniem z różnych powodów. W poniższej sekcji opisano problemy z wdrażaniem funkcji, które mogą powodować błędy podczas wdrażania agenta usługi Log Analytics dla rozszerzenia systemu Windows.
Uwaga
Agent usługi Log Analytics dla systemu Windows to nazwa używana obecnie w usłudze Azure Automation dla programu Microsoft Monitoring Agent (MMA).
Scenariusz: wystąpił wyjątek podczas żądania klienta WebClient
Rozszerzenie usługi Log Analytics dla systemu Windows na maszynie wirtualnej nie może skomunikować się z zasobami zewnętrznymi i wdrożenie kończy się niepowodzeniem.
Problem
Poniżej przedstawiono przykłady zwracanych komunikatów o błędach:
Please verify the VM has a running VM agent, and can establish outbound connections to Azure storage.
'Manifest download error from https://<endpoint>/<endpointId>/Microsoft.EnterpriseCloud.Monitoring_MicrosoftMonitoringAgent_australiaeast_manifest.xml. Error: UnknownError. An exception occurred during a WebClient request.
Przyczyna
Oto niektóre potencjalne przyczyny tego błędu:
- Serwer proxy skonfigurowany na maszynie wirtualnej zezwala tylko na określone porty.
- Ustawienie zapory zablokowało dostęp do wymaganych portów i adresów.
Rozwiązanie
Upewnij się, że masz otwarte odpowiednie porty i adresy na potrzeby komunikacji. Aby uzyskać listę portów i adresów, zobacz Planowanie sieci.
Scenariusz: instalacja nie powiodła się z powodu przejściowych problemów ze środowiskiem
Instalacja rozszerzenia usługi Log Analytics dla systemu Windows nie powiodła się podczas wdrażania z powodu innej instalacji lub akcji blokującej tę instalację.
Problem
Poniżej przedstawiono przykłady komunikatów o błędach, które mogą zostać zwrócone:
The Microsoft Monitoring Agent failed to install on this machine. Please try to uninstall and reinstall the extension. If the issue persists, please contact support.
'Install failed for plugin (name: Microsoft.EnterpriseCloud.Monitoring.MicrosoftMonitoringAgent, version 1.0.11081.4) with exception Command C:\Packages\Plugins\Microsoft.EnterpriseCloud.Monitoring.MicrosoftMonitoringAgent\1.0.11081.4\MMAExtensionInstall.exe of Microsoft.EnterpriseCloud.Monitoring.MicrosoftMonitoringAgent has exited with Exit code: 1618'
'Install failed for plugin (name: Microsoft.EnterpriseCloud.Monitoring.MicrosoftMonitoringAgent, version 1.0.11081.2) with exception Command C:\Packages\Plugins\Microsoft.EnterpriseCloud.Monitoring.MicrosoftMonitoringAgent\1.0.11081.2\MMAExtensionInstall.exe of Microsoft.EnterpriseCloud.Monitoring.MicrosoftMonitoringAgent has exited with Exit code: 1601'
Przyczyna
Oto niektóre potencjalne przyczyny tego błędu:
- Inna instalacja jest w toku.
- System jest wyzwalany do ponownego uruchomienia podczas wdrażania szablonu.
Rozwiązanie
Ten błąd ma charakter przejściowy. Ponów próbę wdrożenia, aby zainstalować rozszerzenie.
Scenariusz: przekroczenie limitu czasu instalacji
Instalacja rozszerzenia usługi Log Analytics dla systemu Windows nie została ukończona z powodu przekroczenia limitu czasu.
Problem
Poniżej przedstawiono przykład komunikatu o błędzie, który może zostać zwrócony:
Install failed for plugin (name: Microsoft.EnterpriseCloud.Monitoring.MicrosoftMonitoringAgent, version 1.0.11081.4) with exception Command C:\Packages\Plugins\Microsoft.EnterpriseCloud.Monitoring.MicrosoftMonitoringAgent\1.0.11081.4\MMAExtensionInstall.exe of Microsoft.EnterpriseCloud.Monitoring.MicrosoftMonitoringAgent has exited with Exit code: 15614
Przyczyna
Ten typ błędu występuje, ponieważ maszyna wirtualna jest pod dużym obciążeniem podczas instalacji.
Rozwiązanie
Spróbuj zainstalować rozszerzenie agenta usługi Log Analytics dla systemu Windows, gdy maszyna wirtualna jest pod niższym obciążeniem.
Następne kroki
Jeśli w tym miejscu nie widzisz problemu lub nie możesz rozwiązać problemu, wypróbuj jeden z następujących kanałów, aby uzyskać dodatkową pomoc techniczną:
- Uzyskaj odpowiedzi od ekspertów platformy Azure za pośrednictwem forów platformy Azure.
- Połącz się z @AzureSupport oficjalnym kontem platformy Microsoft Azure, aby poprawić jakość obsługi klienta. Pomoc techniczna platformy Azure łączy społeczność platformy Azure z odpowiedziami, pomocą techniczną i ekspertami.
- Zgłoś zdarzenie pomoc techniczna platformy Azure. Przejdź do witryny pomoc techniczna platformy Azure i wybierz pozycję Uzyskaj pomoc techniczną.