Udostępnij za pośrednictwem


Windows 10 でトースト通知が表示されないことがある

こんにちは、Platform SDK (Windows SDK) サポートチームです。

今回は、Windows 10 においてトースト通知が表示されない現象についてご案内します。

 

現象

Windows 10 上で動作するアプリケーションから API 等を用いてトースト通知しても、稀に期待したタイミングで表示されない場合があります。

 

背景

Windows 8 以降、トースト通知と呼ばれる機能が提供されました。

OS やアプリケーションが発する通知を画面右端に表示し、ユーザーに通知やアクションを促すことができます。

Windows 10 では、トースト通知に関する仕様変更があり、バルーン通知をトースト通知に変換する機能が既定となっています。

 

原因

トースト通知が期待する表示にならない原因として、ユーザー プロファイルの破損が考えられます。

ユーザー プロファイルは、OS よってユーザー アカウントごとに作成される領域で、ユーザー アカウントに紐付けられたファイルやシステム設定を管理します。

たとえば、トースト通知等、Windows の機能やアプリケーションによっては、ユーザー プロファイル配下のファイルやレジストリで各種情報を管理している場合があります。

このため、何らかの理由によりユーザー プロファイル配下の各種情報の整合性に問題が生じた場合、当該機能が正常に機能しなくなります。

残念ながら、ユーザー プロファイル内に不整合が生じた原因をあとから調査することは困難です。

 

対処方法

ユーザー プロファイルの破損が原因で、トースト通知を表示できない現象が発生した場合、OS の設定やアプリケーション側の実装等で対処することはできません。

この問題が発生した場合には、以下の手順にて、新しいユーザー プロファイルを作成して復旧することをご検討ください。

1. 整合性に問題が生じているユーザー プロファイルを削除します。

  1. 現象が発生しているユーザー アカウント以外のアカウントで、再現端末へログオンします。
  2. コントロール パネルの [システムとセキュリティ] - [システム] から [システムの詳細設定] を開き、[詳細設定] タブの [ユーザー プロファイル] にある [設定] をクリックします。
  3. [このコンピューターに格納されているプロファイル] のリストから、現象が再現しているユーザー アカウントを選択し、[削除] をクリックします。

2. ユーザー プロファイルを削除したユーザー アカウントで OS にログオンします。このとき、OS によってそのユーザー アカウント用のユーザープロファイルが新しく作成されます。

 

なお、通知が目的の場合は、トースト通知をバルーン通知に変更することで回避できる可能性もあります。
変更方法の詳細については、以下のブログをご参照ください。

Windows 10 におけるトースト通知の文字数制限について  <https://blogs.msdn.microsoft.com/japan_platform_sdkwindows_sdk_support_team_blog/2016/02/11/windows-10/>