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SharePoint 2010 : Unable to connect to the search service after Search Service Application restoration

Issue:

After restoring the Search service application from the SharePoint 2010 Central Administration site successfully. When you try to perform a search, it gives the following message : The search request was unable to connect to the Search Service.

Cause:

Check if you have the Search Application proxy restored successfully under the Search Service Application, if not then that’s where the problem lies.

So when you take a Search Service Application backup from Central Administration site. Ensure that you take the backup of the Search service application proxy separately.

By  default, the backup UI from Central Administration site, allows you to only take one at a time. Which means that you have to perform backup twice. One for
1. Search Service Application
2. Search Service Application Proxy

So if you have deleted the Search Service Application from the UI before taking the Search service application proxy backup, then you can create the proxy using PowerShell.

Workaround:

The below command will fetch the name of the Search service application in the variable, it is useful when you have multiple Search service application and was a specific SSA has an issue:

$getsearchapp = get-spenterprisesearchserviceapplication "<Name of the Search Service Application>"

This command provided the name of the proxy to the associated with the Search service application.
$setproxy = new-spenterprisesearchserviceapplicationproxy -name "Name of the Search Service Application Proxy" -Uri $getsearchapp.uri.absoluteURI

Verify the search service application proxy is online.  It should be online by default.
$setproxy.status

If it's not online, you can run the following command to change the status:
$proxy.status = “online”

Hope this helps.