When you attempt to move mailbox from/to Exchange Online, you receive the error "The call to Microsoft.Exchange.MailboxReplicationService timed out"
Symptom:
When you attempt to move mailbox from/to Exchange Online, you receive the error:
The call to 'net.tcp://server name/Microsoft.Exchange.MailboxReplicationService server name' timed out. Error details: This request operation sent to net.tcp://server name//Microsoft.Exchange.MailboxReplicationService did not receive a reply within the configured timeout (00:01:00). The time allotted to this operation may have been a portion of a longer timeout. This may be because the service is still processing the operation or because the service was unable to send a reply message. Please consider increasing the operation timeout (by casting the channel/proxy to IContextChannel and setting the OperationTimeout property) and ensure that the service is able to connect to the client.
Cause:
The DataImportTimeout property may be set too low.
Resolution:
To isolate the issue, you may check how it works if you increase the timeout with the following steps:
- On the Client Access server, open the following file with a text editor such as Notepad:
ExchWebEWSweb.config
- Locate the following section in the web.config file:
<!-- Mailbox Replication Proxy Server configuration -->
<MRSProxyConfiguration
IsEnabled="true"
MaxMRSConnections="100"
DataImportTimeout="00:01:00" />
- Make sure value of the IsEnabled property is set to true.
- Check the value of the DataImportTimeout property. The minimum value is one minute (00:01:00), and the maximum value is 30 minutes (00:30:00).
- Set a higher value, but make sure the value is less than 30 minutes.
- The recommended value for this field should be 00:20:00 (20 minutes).
- After the values are configured correctly, save and close the web.config file.
More information and documentations for your reference:
Troubleshooting Mailbox Moves